Typing a character using Keyman seems to activate a modifier key

This just started about 2 weeks ago. When I type using the Keyman Yiddish Pasekh keyboard, it enters the first character, then when I hit another key, I might get a dropdown menu or other function when I touc a second character key. This suggests to me that the CTRL or ALT key was pressed. I’ve uninstalled Keyman and reinstalled, and I have the same problem. Using Windows 10 Pro (21H2) and Keyman 15.0.271. I have sent a diagnostic report.

Hello @astrojet990,
Thank you for the diag report, it wasn’t attached so I will see if I can find out why that happened. This seems to align with an issue a few users have seen and I have not been able to reproduce my end. There is this issue raised Issue #7337. I have made an approvement which is available as pre-release version Keyman version 16.0.86-alpha, which you could install and see if the problem still occurs.
Alternatively, you could also try turning off serialized input. Ultimately we need to fix the problem this is just to get you going in the mean time.

To disable Keyman’s serialized input:

  1. Open Keyman Configuration
  2. Select Options / Keyman System Settings
  3. For engine.compatibility.serialize_input, enter the value 0.

  1. Click Apply, Close, and then restart Keyman