Things that have never worked in Keyman Developer!

Hi all,
I have had issues with the following in many versions of Keyman Developer:

:point_right: On-screen “Import from layout” crashes systematically in every version of KD I’ve used.

:point_right: Insert mode (Unicode characters) only outputs “character”, no matter what mode is selected (Code, Name ). Dragging on to the touch layout also always outputs character.
:point_right: Copying and pasting on keyboard design code field

Thats All Folks…for now.
Cheers
Ibrahima

Hi.
When importing fails for me, it usually gets stuck on a certain letter. Identifying that letter has been a key to solving the issue. If some of your key combinations conflict with Keyman’s hotkeys, it will fail.

You can either remove the conflicting key from your code and reimport or deactivate its shortcut for Keyman temporarily. Using a combo that is reserved by default in Kerman isn’t recommended, as others will be unable to use it.

As for Character map, I can offer a partial solution, right click on a letter in the map and choose Insert Mode>Code, Character, or Name. Put your cursor in a code area for typing and double-click on the letter to output any of the three. Dragging doesn’t seem to work in the code.
I mostly work on the code tabs, so I hadn’t noticed that it tended towards character in the GUI as you describe, nor had I tried to drag and drop. Maybe there’s an encoding reason to prefer literal characters in the OSK, but I don’t know.

Thanks a lot
No matter what I do, it seems not possible to output anything but letter.
Cheers

Can you provide some more detail on what error you are receiving?

The character map will only drop characters onto non-Code fields (it doesn’t make sense to drop a character code onto a keycap, for example, or into the keyboard name field). Try dropping a character code into the Layout/Code (or source) view.

There is a limitation at present with the Touch Layout Code view in that we don’t currently support the Javascript code format \uxxxx but only U+xxxx as found in the .kmn source, so for now the character map will only drop characters into the Touch Layout Code view.

Can you give a bit more detail on what you mean here, e.g. a step-by-step reproduction of the issue?

Also important are the exact version number(s) you are experiencing the problem with – even if it’s multiple versions.

Thank you very much Marc,
:point_right: For on-screen import from layout issue, it displays a small box where the import process is displayed. Then it just freezes on “importing…x or y”.
I will try to post a screenshot.

:point_right: For dropping code from map, I only drop characters on keycaps. But I do need to drop code on touch layout design view, which you said is not supported.

:point_right: Copying/cutting/pasting does not work on design view for code field (U_003F for example). Thats what I meant. You can only type the code but copy or paste it.
As for version numbers I am using 13 latest. But I have had similar issues from version 12 and later.

Thanks.

This is almost definitely what Matthew_Lee wrote about above. Turning off hotkeys will resolve it. We also have a plan to improve this function in Keyman Developer 15, so it will not interact with Keyman hotkeys at all, as part of our Keyman Core integration.

I’ve opened a feature request for this: #4701

Can you try this with version 14.0 beta?

@ibrahima Do you still have issue with the OSK when using Keyman 14 latest stable?

Hi
I haven’t used OSK yet. I was scared to mess up my keyboard, so I only created a mobile touch keyboard.
But I am going to create a desktop keyboard with oak to see. But I always had issues. Maybe there are things I don’t do right.
Cheers