Text from BLOOM book not appearing in RAB app

I’m trying to help a user build an App with RAB. She is using several BLOOM books as the source. The App which is produced only shows the illustrations, but with no text below each one. I wondered if this was something to do with using a complex RTL script, so tried adding a .DOCX file as the source for one of the books in the App and that worked fine (in other words, the Android device is able to render the text fine).

I have also tried to experiment with simple roman texts, and managed to get that to work, and even managed to see the text (from the BLOOM book) for one complex (Indic) script. But I can’t see how to tell RAB what font/size/colour to use for any imported BLOOM books.

I’m wondering if the imported books are trying to use a font that isn’t displaying at all (but can’t see where to set that - as anything I have tried so far hasn’t resulted in changes to the App). Has anyone else faced this kind of issue before, and if so, what is the secret to making it all work well?

(Just in case it matters, I’m using BLOOM 4.1.14 and RAB .5)

Knock, knock… anyone home?

I am having a similar problem here. We can see the text when the phone is oriented in portrait, but we lose the text when the phone orients to landscape. It’s as if the picture takes the whole screen. When we have a page that is just text, and if it’s in landscape mode, the screen goes blank.

I have the Bloom collection files for the user that MarkP was working with when he posted about this issue last week.

The Bloom books have illustrations and text. I added the Bloom books within a new RAB App, chose the appropriate font from the Font page, then built the app.

The user mostly uses Scheherazade for the Bloom books, so that’s what I selected within RAB (from the Fonts page). With Scheherazade, none of the text in the book displayed. With Andika New Basic, some of the text showed, but for most books it did not display.

(And for those books where it does display in Portrait view, it disappears in Landscape view and the picture shows full-screen).

By clicking on the Books page within RAB, then Styles, it seems possible to set the font size, but it didn’t seem to change how the Script actually displayed in the App.

Could it be related to the page size/layout within Bloom? Most of the books in the Collection use the Big Book layout, so they’re created for A4 landscape size.


sounds like my problem is a different one.