Swipe not working in one direction

I’ve created an app with a number of ‘books’, each broken into chapters using \c markers. The ToC then points to different chapters.

The problem comes which navigating from one chapter to the next by swiping. The app is RTL and swiping left to right correctly advances us to the next chapter. However swiping right to left does NOT make us go to the preceding chapter… it does nothing.

Is this a bug in RAB? Is it possible it’s something I just set up wrong in my files?

Some how I missed this.

Can you share your APK file and your whole project for us to test?

If you share on DropBox or Google drive, let me know the link by personal message.

I was able to download the apk and the project.

None worked on my emulator, but the app I built worked on my phone.

Swiping right to left worked. Is there something else you are doing first before the swipe RTL stops working. If we can’t find a way to make it always happen then it is unlikely to get fixed.

Ian,

This took me down a rabbithole of testing. I was originally happy to hear your reply and thought that maybe the problem was just my phone. Sadly that doesn’t appear to be the case, and the problem appears to plague any RAB or SAB app I build. I’m interested in testing builds from other people, particularly in RTL languages. Did you say that you built the app? If so, could you send me the arm64 version you created?

If your version works, then I might ask you to send me your sdk folder so that I can test using it. I had a horrible time getting the Android sdk to work correctly, so I’m not 100% confident my build is good.

It’s not that RTL swiping sometimes works–it never does. LTR moves to the next chapter, but RTL swiping doesn’t move to the previous one.

What I’ve discovered.

Works:
Amazon Fire HD 8 2020 (stock rom; arm)
One of team member’s phone. I don’t know details other than it is arm64

Doesn’t work:
Moto g7 Plus (running Android 11 via LineageOS; arm64)
Moto g8 Plus (running Android 10 via stock rom; arm64)
Moto Droid Turbo (running Android 9 via LineageOS; arm)
Android Studio emulator, Android 10, x86

–Malachi