[SOLVED] Keyman 12.0 fatal error for older Android devices

I have been using Keyman for Android for many years on my Smartphone Samsung Galaxy J1.

Since October I receive the following error message when I start Keyman: “Fatal error with null. Loading default keyboard”.

I use version 12.0.4209 of Keyman and Android 4.4.4

Hi @Fran

Keyman 12.0 introduced a new feature for Predictive Text services that can be used with keyboards.
Unfortunately, it’s currently incompatible with some older devices (Android 4.4 to Android 6.0) and prevents a Keyman keyboard from loading.

@joshua_horton started working on a fix but we don’t have an estimate when that will be ready.

Sorry for the inconvenience, but can you roll back to Keyman 11.0.2107 for now?

We are working hard on trying to get a fix by the end of this week to resolve this on older Android devices.

Thank you very much.

Sorry for the delay. We’ve made progress but there’s still some remaining issues to get Keyman working on older Android devices.

Good news @Fran

Thanks to @joshua_horton 's persistence, Keyman 12.0.4215 should work for your device!
I was able to use the predictive text on the default sil_eurolatin keyboard it in an emulator.

Please download the Keyman update and see if it works for you.

Yes, Keyman 12.0.4215 works. Thank you very much.

1 Like

That’s great news; thanks for the feedback!