[solved] Keyboard package error

When I installed my new language keyboard myanmar3 into my samsung tab s7 andriod tablet, un error appear like this “keyboard pacakage has no touch-optimized keyboard to install”. Pls fix and reupload. Thank you very much.

The myanmar3 keyboard is not currently supported on Android tablets. I’ve documented an issue on the keyman.com website where the Windows keyboard is being offered to you – but a Windows version of the keyboard won’t work on Android!

We’ve noted the request for Android support for the keyboard at #1497 :slight_smile:

1 Like

But before I updated keyman to ver 14, I can use myanmar3 sil keyboard in my andriod tablet. Its all about my silly, I deleted my current using version of keyman before I downloaded the newest version of keyman. Window version is ok. All we need is andriod version. :crazy_face:Thanks in advance.

Pls let me know when myanmar3 keyboard is available.

We’ll update this forum when an Android version is available :slight_smile:

1 Like

I can confirm that sdysart is currently working on adding a touch layout to sil_myanmar_my3!

1 Like

Hi there
Attached is a test build of the updated keyboard package.
Can you try to install this with Keyman 14 for Android and tell us if it works for you?

Another user had given directions to @Scott_Dysart, so the new layout might have some differences from what you expect.

Please provide feedback on the pull request

sil_myanmar_my3.kmp (295.7 KB)

1 Like

Wow! It works 100%. Iḿ so happyyyyyyy :smiling_face_with_three_hearts: and thank you very much. Our Myanmar unicode language default comes with andriod tablet and unicode by keyman has a little different way in typing. I think keyman edit user friendly way of type. Thanks again. You are great!!!

1 Like

There is one inconvenient left. Whenever I changed one application to another, Keyman keyboard doesn’t work automatically. So I did on screen keyboard radio button on. Typing with on screen keyboard button on is not good because whenever I touch the screen, the huge keyboard layout appear and it disturbs my view. Can you pls fix this problem. The original default samsung keyboard doesn’t have that problem. I would like to suggest that the keyboard size should be cutomized in its setting. Doing good without on screen keyboard appear is the best. Hope youĺl understand what I mean. Thanks.

You might be able to switch to the Keyman keyboard by pressing Ctrl+Tab on your Bluetooth keyboard?

Yes. I did. I can choose the language but when I typed nth appear. It appears only when I touch the on screen keyboard again.

@ThetNaing, thank you for the additional feedback. @darcy are you able to reproduce this?