Right alt + characheters not typing, linux

Hi folks.
I’ve mentioned this before in other posts, but though it simpler just to create a new Topic. Using Khmer Angkor sometimes I cannot type any character that requires right alt: ឝ ឞ ៖ Other times it is fine. Previously it happened in Flex, just now on libre writer (6.1.5). Restarting libre office did not fix it. Restarting the computer did fix it. Will let you know if it happens in other programmes.

Ian

Just happened again, seemingly system wide (gmail, gedit, libre writer). However, seems to be solved just by selecting another keyboard then reselecting Khmer Angkor. Should have tried that before. So probably not a big problem so long as you know the workaround.

The Khmer Angkor keyboard seems to use some of the “reserved” keys in Keyman RALT SHIFT K, RALT SHIFT M and RALT SHIFT O.

We’ve started putting this statement in keyboards that use those keys.

This keyboard makes use of SHIFT+RALT+K, SHIFT+RALT+O, and SHIFT+RALT+M keys which are set by default when Keyman is installed. To use this keyboard, you must go to Configuration…/Hotkeys and select the hotkey for “Switch Keyman Desktop Off”. Either change the hotkey or turn it off. Do the same for “Open Keyboard Menu” and for “Open Language Switcher”.

I’ll open an issue to add that statement to this keyboard.

Note: that’s only for Windows; @hodgsonian was experiencing this issue on Linux.

I had a similar problem when using the Tagmukay font on Ubuntu Linux 18.04 which has a number of ligatures that require use of the Right-Alt key. My problem had to do with the fact that my PC has an AltGr key, but it wasn’t functioning as an AltGr key would in Windows. The solution was to remap the key to “Super Right” using the following method:

  1. install gnome-tweaks
  2. open tweaks and go to the menuitem ‘keyboard & mouse’
  3. Next to the “compose key” line click the “disabled” button
  4. In the resultant dialog click the toggle switch to turn compose key function on.
  5. Then select the “Right Super” radio button
  6. close the dialog and tweaks

After doing this I was able to access the glyphs I needed using the AltGr key.

1 Like