RAB won't open

Hi,
I did a successful build, and closed the RAB, and when I tried to open it again the next day, all I got was the little rotating circle for a fraction of a second - no error message or anything else.
I re-installed RAB and the JDK, but it makes no difference. Still won’t open.
Any suggestions? Please keep them as simple as possible- I’m in way beyond my skill level here.
Gene

Hello Gene. Did you find a resolution to your RAB problem? Mine will not launch either. Have followed several suggestions with no results. At a loss as to where to get help.
Any advice is appreciated.
Chris

What do you get when you type java --version at the command prompt?
What do you get when you type where java at the command prompt?

Can you find rab.bat and double click that. Does that work?

Edit the first line of rab.bat from:
@echo off
to
@echo on
You have to have admin privileges to do that.
Then open a command prompt at the folder where you find rab.bat and type in:
rab and press enter.

If this fails then copy the whole text and report back here to the forum.

It is possible that this RAB loading problem is due to a corrupted app project that RAB is trying to load when it launches.

We have added a couple of checks in the code for such a situation and have released an updated version of RAB today, dated 23 January 2019.

Please see if this helps at all. Thanks.

Hello Chris, Ian and Richard,
Yes, the new version that Richard just made available, opens and works great! And I didn’t even lose my ongoing work on the two apps I was preparing. Thanks so much. Now I’ll be able to get back to work again.
Thank you to Ian also for his help.
Grace and Peace,
Gene

I can’t get RAB or DAB to launch. When I run it from the command line using:
java -jar reading-app-builder.jar
I get this error message:
java.lang.NullPointerException
at org.sil.app.builder.common.settings.BuildEnvironment.findJdkFolderFromRootDir(BuildEnvironment.java:1021)
at org.sil.app.builder.common.settings.BuildEnvironment.findJdkFolderOnWindows(BuildEnvironment.java:1099)
at org.sil.app.builder.common.settings.BuildEnvironment.findJdkFolder(BuildEnvironment.java:1132)
at
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
.
.
etc

I can’t seem to get RAB to launch.
Tried:

  • uninstall / re-install the JDK, and both App builders,
  • HKLM fix previously suggested
  • Set Environment variables to point to java.exe

running RAB 5.6 and DAB 5.6
any other suggestions?

Can you give me what is reported from a Command Prompt when you type:

where java

Also what path is your JDK installed at? It seems there is a problem with this.

Then also include the following:
C:\Users\<your-user-name>\AppData\Roaming\SIL\App Builder\rab-settings.xml