RAB will not Launch


#1

Hello, looking for advice…
Several months ago RAB was working. Just started building a new App but could not creating timing files with Aeneas because it said there was no audio file selected. But there is/was. After a few tries the App would not relaunch.
Computer is updated, shut down/restarted, recently professionally cleaned … no viruses.
JDK is updated correctly for Windows 8.1 64bit.
SDK is extracted in c:\sdk
Uninstalled everything and reinstalled RAB. It will still not relaunch to complete the tools install.
Security is set to full control.

Advice? What to try next.
Thanks,
Chris


#2

You can usually find the rab.bat file here: C:\Program Files (x86)\SIL\Reading App Builder\rab.bat

Double clicking that in Windows Explorer or starting from a command prompt should start it.

Some programs hijack the association of .jar files with java.exe. The batch file gets around that.

Ian


#3

Thank you Ian.
Did that several times although not familiar with the “command prompt” process.
This is what I have …


#4

And this …


#5

So … any other advice out there???


#6

The rab.bat assumes that Java.exe is in your path.

So your Java installation is not typical. A typical Java Installation will put java.exe into the path.

So to get the rab.bat to work you need to put the full path in for Java.

So this iine:
java -cp “%~dp0/bin/reading-app-builder.jar” org.sil.app.builder.reading.ReadingAppBuilder %*

Need to change to something like this:
“C:\Program Files\Java\jdk1.8.0_101\jre\bin\java.exe” -cp “%~dp0/bin/reading-app-builder.jar” org.sil.app.builder.reading.ReadingAppBuilder %*

Now your path to java.exe may be different because of version numbers.


#7

Hi Ian,

Having a similar issue here at a workshop. I’ve tried the edits as suggested but it’s still failing to load. Here is the specifics of my edit to the rab.bat file.

The first error we received was:

Unable to install Java

There are errors in the following switches: “C:\Program Files (x86)\SIL\Reading App Builder\bin|reading-app-builder.jar”;.

Check that the commands are valid and try again.

I then edited the bat file as follows:

“C:\Program Files (x86)\Java\jre1.8.0_181\bin\java.exe” -cp “%~dp0/bin/reading-app-builder.jar” org.sil.app.builder.reading.ReadingAppBuilder %*

I got the path to the jave.exe by finding and copying it and adding it to the line in the rab.bat file.

When I click on the RAB builder icon I no longer get the original error. What happens now is a command window opens and that is all that happens.

Thanks for your input.


#8

The first error may be because the user account is not an administrator account.

I’d open a command window in the folder where rab.bat is and start it that way. See if there is any feedback in the command box? Though if I start mine that way nothing shows until I close RAB.

Typing where java in a command prompt will let you know if it finds Java in the path.

What does the Registry HKLM\SOFTWARE\Classes\jarfile\shell\open\command show?

Is there an Antivirus setting that is preventing RAB from starting from the command prompt?


#9

Ian, I’m still not having success either. Even with some very knowledgeable help … following the suggestions posted here. Something internal with RAB?? Problem started with updates of RAB and JAVA. I now have Windows 10 but that did not solve anything.

Apparently RAB has a problem with Windows? Worked fine before the updates.
What are my options if this is the case?


#10

Decided to install Scripture App Builder instead. Same problem.
Got this message …
Screenshot%20(1)


#11

Hi Ian,
We have 3 of the 4 machines working - sort of - per the rab.bat edit we did yesterday. This method opens a command window that remains blank but after a wait of 30 seconds or more RAB does open. From there we’ve discovered what I think are two different issues on two different machines.


The first error happens on two of the computers. -
When a project is ready and the build button is clicked for Android a window opens showing a progress bar up to 100% and on reaching that a commend or terminal window opens showing the build process. This is the one where if there is no internet the build fails. On these machines we never reach that point - no terminal window ever appears.
Checking one of these the key you asked about (Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\jarfile) is as follows. “C:\Program Files\Java\jre-10.0.2\bin\javaw.exe” -jar “%1” %*

The other error:
The other machine appears to be building the apk successfully but with the “Tools > Settings > After Build” options selected to install and run on an attached device selected nothing is happening. I confirmed my phone does not work either and I have done this multiple times.

I don’t understand what all needs to take place but I did see the following:
“Starting a Gradle Daemon, 1 incompatible and 1 stopped Daemons could not be reused, use --status for details”

At the end of the build, which is successful, RAB says there are no devices attached, which there are as my phone shows it is attached and in the USB Debugging mode.

I’m not sure that helps much but that’s what I noticed.
Cheers,
Dan


#12

I’m completely “dead in the water”. Sometimes the command window … for both RAB & SAB … flashes for 1/2 a second, then nothing.

Are there other good App Builders out there that could be recommended?


#13

Sorry to hear of the RAB launch problems, Chris. We do much of the RAB development using a Windows 10 machine so that is normally the first operating system we try it on.

The Reading App Builder program is a Java application and is run using the Java runtime environment (JRE) on your computer. The main RAB program file has a “.jar” extension. This file type should normally be associated with java.exe, but on some machines the file type associations get messed up and jar files do not run as expected when clicked on.

To better understand the problem, here are some diagnostics you can do:

  1. Open a command prompt , by typing “cmd” in the search box. Type “java --version” to get the Java version. You should see something like this:
C:\Users\Richard>java --version
java 10.0.1 2018-04-17
Java(TM) SE Runtime Environment 18.3 (build 10.0.1+10)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.1+10, mixed mode)
  1. Find out what program the .jar extension is associated with. To do this, type “assoc .jar” in the command box:

C:\Users\Richard>assoc .jar
.jar=jarfile

Do the same with jarfile “assoc jarfile”:

C:\Users\Richard>assoc jarfile
jarfile=Executable Jar File

  1. If .jar and jarfile are not associated with an executable jar file, it might work to delete the association and then reinstall the latest version of Java.

To delete an association:

C:\Users\Richard>assoc .jar=

The latest Java (JRE) install can be found at: https://www.java.com

If you have tried all of these things and all looks well… but RAB still does not load, please let us know and we will try and think of something else to try!


#14

Thank you, Richard!! I’m attempting to work through your suggestions.

Not a good start :slight_smile: Does this give us any idea what might be wrong with my computer?
I had already installed the latest version of both Java and RAB … this is when the problem started. Then I upgraded to Windows 10.

This is what I got following the first direction:


#15

Yes that does not look good. Java is not functioning as it should.

I’d be uninstalling all Java versions. Get a new download of Java (in case the last one is corrupt) and re installing. Then try that again.


#16

Uninstalled and reinstalled several times.
Reinstalled after upgrade, restarted computer, etc. etc.


#17

The issue you have is like this: http://www.java67.com/2015/10/error-could-not-open-java-jmv-cfg-lib-eclipse.html
Eclipse is also a .jar file application like RAB.

Do you want to try and see if his solution works for you?


#18

Thank you, Ian.
I’ve looked into this, did a thorough search and it seems this is not my issue.
I did do another (5th time) Java un/reinstall. RAB will still not launch.

However, SAB now does!!! Yay! It launched and I was able to download all the relevant files. Apparently it is similar enough to RAB for my purposes so will give it a go. At this point I do not know if it will actually create/complete the entire App build process.
Will report what happens.


#19

That is good news Chris.

So Java seems like it is okay now. Then I’d uninstall then reinstall RAB, but I’d guess you have done that.

I’ll wait to hear how it goes.


#20

Ian, I did do a RAB reinstall … following advice (given in my other post) about installing RAB last, but it simply will not launch. Moving ahead with SAB today.