Problems with keyboard not working after restarting the machine

I am using the Eastern Yiddish keyboard. I instal Keyman and download the keyboard. For the rest of that session it works perfectly and I have an ENG or a Yiddish symbol on my task bar. As soon as I reboot it stops working. I have the keyman icon and I can choose the Yiddish keyboard but the on screen keyboard shows English letters and if I use it in word, it types in English. The cursor changes very slightly but it still tyoes English letters. I couple of months ago, it worked fine. Can anyone help.
Thanks
Simon

Hi @simonp, welcome to the community.

It’s hard to tell what is happening there, but could you provide the following information to help us figure out.

  1. What operating system are you using? Windows or macOS? And what version?
  2. What version of Keyman are you using?
  3. If you are on Windows, can you try and send a diagnostic report using the instructions here.

Hi and thanks for the reply. I’ve sent the diagnostic report.
The windows version is here:
Edition Windows 10 Pro
Version 21H1
Installed on ‎04/‎11/‎2020
OS build 19043.2130
Experience Windows Feature Experience Pack 120.2212.4180.0

They Keyman version is 15.0.270

I have a UK English keyboard.

Thanks for your help

Simon Prager

Hi Simon,

From the diagnostic report you’ve sent, I was told that Keyman app was not running. Could you ensure that Keyman is open and running. Keyman is running if its icon is shown in the taskbar.

Hi Makara

I’m now attaching a screenshot pasted into a word doc. You can see that Keyman is running and I’ve chosen the Yiddish keyboard. The on screen keyboard is showing Yiddish as the selected language and actually the cursor is a Yiddish one and to the left of the text as in Yiddish (you can’t see that). However, the characters are not Yiddish they are English.

Thanks for your help

Simon Prager

(Attachment screenshot.docx is missing)

Hi Makara
My attachment was rejected so I’m now pasting it in. I hope you can read it.

Thanks

Simon Prager

I’ve just got a chance to look into this. Thanks for your patience.

It looks like you are don’t have the right keyboard installed. From the Keyman keyboard library, “Yiddish Pasekh” is what is found for “Easter Yiddish” language. I have installed the keyboard and it is working as expected (see the screenshot below).

Here is the link to the keyboard: https://keyman.com/keyboards/yiddish_pasekh.
If you use a different keyboard, please drop it here so that I can test it on my side.

Hi Makara

I do a fresh install of Keyman asking for the Yiddish Pasekh Aleph keyboard. I select the Yiddish keyboard and it works perfectly. It shows the yiddish keyboard, it types yiddish characters and in the taskbar it shows a square icon representing the Yiddish keyboard.

Then I shut down the pc and start it again. I open Word and select the Yiddish keyboard again. This time the on screen keyboard shows that I’ve selected Yiddish but it shows English characters. When I type in Word I get English characters but with a Yiddish cursor which is on the left hand side of the text as a Yiddish cursor should be (because Yiddish is written right to left). On the taskbar there are no square icons but just the standard keyman icon.

There’s only one thing worth mentioning: The keyboard is labelled Yiddish-US but I’m using a UK English keyboard. Could that make a difference? It doesn’t when I first install.

Thanks for your help.

Simon Prager

Is it possible that you have not enabled Keyman for Windows to “Start when Windows starts”?

Thanks. No that’s not it:

@simonp, we’re not having much luck here, are we? I would like to organise a remote support session, if that works for you. Can you send me a private message on this forum and we can figure out a mutually compatible time.

Hi Marc
That would be great. I don’t know what time zone you’re in. I am in London, UK. I am free tomorrow Friday after 12.30am and saturday most of the day. Monday and tuesday mornings between 10am and 1pm. I’m also free this evening.
Are any of those any good for you?
Simon

For reference, have replied via private message to @simonp.

I met online with @simonp, and we managed to find a solution.

It seems that the Keyman language association was not ‘sticking’ across reboots. After a reboot, Windows would not show the language indicator in the taskbar, and the Keyman keyboard would not be listed, although the Keyman taskbar icon menu showed the YI yiddish language with the US keyboard.

Solution

  1. In Windows Language Settings, we opened the Yiddish language options and removed some ‘Unavailable Input Method’ entries (perhaps broken Keyman keyboards – unclear?)
  2. In Keyman Configuration, we disabled and re-enabled the Yiddish Pasekh keyboard. This instantly caused the language indicator to reappear, and the Yiddish Pasekh icon to be visible in the menu. The keyboard then worked correctly.
  3. We rebooted, and it continued to work.

Note for Keyman team

Is it possible that the initial install was only enabling the keyboard for the current session? That’s certainly not normally the case but it seems there may be an edge case where this is happening. Something to keep in mind in case we encounter this problem again in the future.

Yes. It works perfectly now. Thanks Marc for your help. Amazing that I’m in London and I got help from someone the other side of the world!
Simon

2 Likes