Problems using a Hindi Keyboard on ubuntu

Hi @newakruti! I just tried again and I can’t reproduce your problem. Here’s what I did:

  1. On a default Ubuntu 22.04 installation in a virtual machine, I installed Keyman 15.0, the Hindi keyboard, and made sure I could type with that keyboard in gedit and LibreOffice.
  2. I installed OpenOffice following these instructions: How to install OpenOffice on Ubuntu 22.04
  3. Rebooted
  4. Started OpenOffice Writer, changed language settings, and tried typing with Hindi keyboard. Everything worked.

Maybe you could try and follow my steps and see if it makes a difference.

If that doesn’t help, please run the following commands in a terminal window and show me the output:

echo $GTK_IM_MODULE
echo $XMODIFIERS
echo $QT_IM_MODULE

Then try setting these environment variables and start OpenOffice from the terminal:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
openoffice4

Hi @EberhardBeilharz, thank you for investigating the problem. I will try the above steps and get back to you.

Hi @EberhardBeilharz, I tried the steps instructed by you. It is working in libreoffice and gedit but not typing in openoffice. Please refer the screenshots.



Hi @newakruti, I’m sorry that it’s still not working for you. Can you please try the following:

  • reboot your virtual machine

  • then run the following command in a terminal window:

    killall ibus-engine-keyman && /usr/libexec/ibus-engine-keyman --ibus --verbose 2>&1 | tee /tmp/keyman-debug.log
    
  • start OpenOffice, switch to the Hindi keyboard and try typing

  • This will create a file /tmp/keyman-debug.log with some debug output. Please send me this file attached to a message.

  • You can press Ctrl+C in the terminal to stop the verbose output of Keyman and reboot (or manually start Keyman with /usr/libexec/ibus-engine-keyman --ibus)

The debug output file might allow me to see what is going wrong.

Hi @EberhardBeilharz, thank you investing your valuable time for this issue. I have tried the steps mentioned by you. Please find the attached file for the log file.

Note: I was not able to attach a file with .txt or .log extension, so I changed the extension to .kmp. Please change the extension for keyman-debug.kmp to keyman-debug.log.

keyman-debug.kmp (20.8 KB)

Thanks, @newakruti! Unfortunately that doesn’t help. It shows the difference that I’d expect if OO doesn’t display anything. As far as I can tell everything works correctly from Keyman side.

Maybe there’s something wrong with the installation, and re-installing OO, ibus and keyman would help? Please try and run the following commands in a terminal window:

sudo apt remove --purge openoffice*
sudo apt remove --purge ibus*
sudo apt remove --purge keyman*
sudo apt autoremove
sudo apt install keyman

Then reboot the machine and download OpenOffice from here: Download Apache OpenOffice from SourceForge.net

Open a terminal window and run (replace Downloads with the directory you downloaded OpenOffice into):

cd Downloads
tar xzf Apache_OpenOffice_4.1.12_Linux_x86-64_install-deb_en-US.tar.gz
cd en-US/DEBS/
sudo apt install ./*.deb
cd desktop-integration
sudo apt install ./*.deb

Reboot again.

If things still don’t work, then please run the same test as yesterday, but start OO in a second terminal window with this command:

openoffice4 2>&1 | tee /tmp/openoffice.log

Please also run the following command which lists all packages installed on your system:

dpkg -l | tee /tmp/dpkg.log

You can put all three log files (keyman-debug.log, openoffice.log and dpkg.log) in a zip file and attach them, then I’ll take another look.

Hi, @EberhardBeilharz, I have tried the above steps. Please find the attachement for output zip file.
output.zip (48.6 KB)

Has this problem source been identified and a fix available?
I also face a similar problem in ubuntu 22.04 LTS/64 bit when using ITRANS vedic sanskrit devanagari
when I type shrI i get सशश्ररी instead of श्री
in editor I get सश्ररी.
I picked the श्री from the url line in the firefox browser where it appeared fine, but in this text box under the same browser, i get errors
appreciate any help

Welcome to the community, @ramOnUbu.

Have you enabled CTL: Hindi under Tools > Options > Language Settings > Languages?

I set that up as well, but no luck yet. besides, the problem is not just with the LibreOffice. even this window where I am typing on the browser, only the english of the ubuntu install works well. with english of keyman, i have issues with using backspace key

regards
ramOnUbu
ps: Is there a way to use the older version of keyman on ubuntu? how? the software app finder installs the latest version

@EberhardBeilharz any thoughts?

@ramOnUbu Keyman doesn’t fully work with Wayland yet, which is the default on Ubuntu 22.04. Wayland significantly changes the way things work. Unfortunately not all functionality we need for Keyman is available, so we’ll have to find workarounds which isn’t easy.

See this reply for how to use X11 instead of Wayland.

noted. thanks for the insights

this seems to be short lived. I am back to the same problem all by itself, have no clue why?? (auto update?)

I cannot choose language through the language menu at the top right of the screen. It does nothing, except default to en; however, I am able to switch language through the Windows/Super key + space key
सशश्ररी is what I get when I need श्री

Is there an alternative to get this working on my Ubuntu 22.04.01 LTS with whatever windowing system?

@ramOnUbu Sorry you’re still having problems. Can you please open a terminal window and run the following commands and show me the output:

lsb_release -a
echo $XDG_SESSION_TYPE
ps -ef | grep ibus
env | grep -e LC -e LANG
dpkg -l keyman ibus
mraman@raman-Vostro-2012:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 22.04.1 LTS
Release:	22.04
Codename:	jammy
mraman@raman-Vostro-2012:~$ echo $XDG_SESSION_TYPE
x11
mraman@raman-Vostro-2012:~$ ps -ef | grep ibus
mraman      2065    1705  0 16:42 ?        00:00:00 sh -c /usr/bin/ibus-daemon --panel disable $([ "$XDG_SESSION_TYPE" = "x11" ] && echo "--xim")
mraman      2067    2065  0 16:42 ?        00:00:00 /usr/bin/ibus-daemon --panel disable --xim
mraman      2439    2067  0 16:43 ?        00:00:00 /usr/libexec/ibus-memconf
mraman      2440    2067  0 16:43 ?        00:00:02 /usr/libexec/ibus-extension-gtk3
mraman      2445    1705  0 16:43 ?        00:00:00 /usr/libexec/ibus-x11 --kill-daemon
mraman      2449    1705  0 16:43 ?        00:00:00 /usr/libexec/ibus-portal
mraman      2460    2067  0 16:43 ?        00:00:00 /usr/libexec/ibus-engine-keyman --ibus
mraman      2852    2067  0 16:44 ?        00:00:00 /usr/libexec/ibus-engine-simple
mraman      4999    4919  0 16:47 pts/0    00:00:00 grep --color=auto ibus
mraman@raman-Vostro-2012:~$ env | grep -e LC -e LANG
LANGUAGE=en_US:en
LC_ADDRESS=en_IN.UTF-8
LC_NAME=en_IN.UTF-8
LC_MONETARY=en_IN.UTF-8
LC_PAPER=en_IN.UTF-8
LANG=en_US.UTF-8
LC_IDENTIFICATION=en_IN.UTF-8
LC_TELEPHONE=en_IN.UTF-8
LC_MEASUREMENT=en_IN.UTF-8
LC_TIME=en_IN.UTF-8
LC_NUMERIC=en_IN.UTF-8

mraman@raman-Vostro-2012:~$ dkpg -l keyman ibus
Command 'dkpg' not found, did you mean:
command 'dpkg' from deb dpkg (1.21.1ubuntu2.1)
Try: sudo apt install <deb name>
mraman@raman-Vostro-2012:~$ dpkg -l keyman ibus
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
++±==============-=====================-============-=========================>
ii ibus 1.5.26-4 amd64 Intelligent Input Bus - c>
ii keyman 15.0.269-1~sil1~jammy all Type in your language wit>

I can reproduce your problem when typing shrI with the *Vedic Sanskrit Devanagari Phonetic (ITRANS) keyboard". This looks like a bug in Keyman. Still investigating…

oh ok. thanks
It seems random. works sometimes…
Will wait for your updates

It looks like PR #7079 might fix this problem. I’ll let you know once a new Keyman version with that fix is available.

See also issue #6803.