Problems using a Hindi Keyboard on ubuntu

I have a keyboard manager installed keyman and have hindi keyboards installed on ubuntu 4.1.12, but when I start typing in openoffice writer using the hindi typewriter keyboard nothing is getting displayed. It does’nt moves the cursor. Any idea how to fix this?

Welcome to the community, @newakruti.

The keyboard with this name “hindi typewriter” cannot be found in Keyman keyboard library. The steps described above is not obvious to me to repro the behavior.

Thank you for your response @makara, I have tried using Hindi (typewriter (m17n)) keyboard from ubuntu keyboards settings. I have also tried hindi typing with Hindi (Kagapa, Phonetic) keyboard and Hindi (Phonetic (m17n)) keyboard using ubuntu keyboards, which are working properly. But other keyboard layouts are not responding in Openoffice then I tried to create hindi typewriter layout using keyman developer tools but it is not working. I installed Hindi Devanagari Phonetic (ITRANS) keyboard from but that too is not responding in Openoffice but works on text editor. Please help me with with this.

Could you tell me a bit more?

  1. Keyman version?
  2. LibreOffice version?
  3. Keyboard name and version?
  4. When you said it’s not working properly, could you give an example of it so that I can try and repro?
  5. Does the keyboard show up in the dropdown menu of the taskbar?
  6. If you’d like me to look into the keyboard you’ve created as well, please DM me the keyboard project.

On Linux 20.04.4 LTS, Keyman version 14.0.293 (package version 14.0.293-1~sil1~focal) is running and used with LibraOffice This keyboard (Hindi Devanagari Phonetic (ITRANS) keyboard) is working as expected.

Please find the version of applications and problem related to them below:

  1. OS - Ubuntu 22.04 LTS (64 bit)
  2. Keyman Version - 14.0.287-1
  3. keyboard name and version - Hindi Devanagari Phonetic (ITRANS) keyboard 1.2.0
  4. The keyboard is working in LibreOffice. There is problem in typing with Apache Openoffice 4.1.12. Please try the keyman keyboards in Apache Openoffice (AOO). Please see the screenshot. I am trying to type by selecting the hindi itrans keyboard but nothing appears on AOO writer screen. The keyboard appears in the dropdown menu of the taskbar. I can even select the keyboard using windowskey + space.

I have tried keyman keyboards and ubuntu keyboards both for hindi typing. When keyman keyboards didn’t work, I tried ubuntu keyboards but that too didn’t responded in AOO writer as mentioned in detail in my previous reply.

I have created a hindi keyboard similar to ubuntu Hindi (Typewriter (m17n)) keyboard using keyman developer with some minor changes but it not working in AOO writer. So, I tried various possibilities to check whether other hindi keyboards using keyman or ubuntu are working or not. Hindi typing with Hindi (Kagapa, Phonetic) keyboard and Hindi (Phonetic (m17n)) keyboard downloaded from ubuntu keyboard input are source are working but others are not.

If the problem doesn’t show up on your side, I will surely DM you the Keyboard project. Please try keyman keyboard in AOO writer for hindi itrans keyboard using keyman or other hindi keyboards from ubuntu input source.

Thanks a lot for the details and your patience.

I have tried on my side and it seems like there is something to do with compatibility. The keyboard works fine in Text Editor.

An issue has been created to track this behavior at bug(linux): Compatibility issues with Open Office on Ubuntu 22.04 LTS · Issue #6728 · keymanapp/keyman · GitHub.

Thank you very much @makara for investigating the issue and creating a bug report. I will keep a watch on it.

I made the changes as detailed in Issue #6728. I am not able to type using hindi itrans keyboard using keyman in AOO. I changed CTL to hindi too, but it is not working. After selecting the keyboard I can type characters like <>?,./ characters but hindi characters are not appearing. Please refer the screenshot.

Specifically, here is what I have set in the Language Settings that enable me to type in Hindi and Khmer.

Would a restart help straighten this out after setting everything as shown above?

BTW, I’m running Keyman 15.0.258-beta here. Lemme try the latest stable.

It’s still working for me with the stable version, Keyman 14.0.287.

I tried to uninstall openoffice and keyman. Reinstall both a fresh with settings as given by you, then I restarted the sytem. It is still not showing hindi letters. But there is a particular behaviour where I have typed english letters with english keyboard first and changed the keyboard to Hindi Devanagari Phonetic (ITRANS) and tried to type. Instead to showing letters it was deleting the earlier typed english letters when I press ‘a’ letter twice.

Let’s try and have a live support session on this issue. I’ll DM you my availability.

That will be very helpful. Please let me know your availability.

Please check your inbox or go to

To summarize what we found out during the live support session: Keyman in OO is also not working when using “Ubuntu on Xorg”. Other ibus keyboard (Hindi m17n) is also not working in OO, so this seems to be a problem between OO and ibus. Both Hindi keyboards work fine in terminal.

@newakruti I know you need OpenOffice, but to further narrow down the problem, could you please try and uninstall OpenOffice and then install LibreOffice and see if typing works in LO?

@EberhardBeilharz, I uninstall OO and installed Libreoffice in the same system. It works on Libreoffice with Hindi Devanagari Phonetic (ITRANS).

@makara @EberhardBeilharz, I tried keyman with hindi keyboard with different ubuntu and openoffice version and windowing system is X11 (Please see the attachement). I made the changes in the language settings but characters are not getting displayed.

Hi @newakruti! I just tried again and I can’t reproduce your problem. Here’s what I did:

  1. On a default Ubuntu 22.04 installation in a virtual machine, I installed Keyman 15.0, the Hindi keyboard, and made sure I could type with that keyboard in gedit and LibreOffice.
  2. I installed OpenOffice following these instructions: How to install OpenOffice on Ubuntu 22.04
  3. Rebooted
  4. Started OpenOffice Writer, changed language settings, and tried typing with Hindi keyboard. Everything worked.

Maybe you could try and follow my steps and see if it makes a difference.

If that doesn’t help, please run the following commands in a terminal window and show me the output:


Then try setting these environment variables and start OpenOffice from the terminal:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus

Hi @EberhardBeilharz, thank you for investigating the problem. I will try the above steps and get back to you.