Problem typing Vietnamese tone markers and diacritics

I’m in the middle of a workshop. Got participants typing their languages using Vietnamese basic keyboard. Most work fine. But on 1 machine I cannot type any of the special characters that should appear when typing the number keys: ăâêôòỏõóõóọ

I’m pretty sure there’s a simple fix, there must be a hot key to switch between typing numbers and the symbols above but I can’t find it.

Anyone know?

Ian

Hi @hodgsonian

Can you provide additional info about the machine have issues?

Which OS? Windows 10, Mac?
Keyman version?
What application are you trying to type in?

In Keyman Configuration, please confirm you’ve got
Vietnamese Basic version 1.1 selected, for the Language Vietnamese (VI).
The keyboard icon on the lower right should also display “VI”

Hi Darcy. It’s Windows 10. Typing in Word and Bloom and Keyman text editor. VI icon is there - the keyboard is selected. Latest KM 12. I actually took an exe file with me, clicked to install it, and it offered to install a more recent one, 12 point something.

I’m still stumped what could be going on.
Normally with Vietnamese Basic, you have to hold the Right Alt modifier to enter numbers.

1 -> ă
Right Alt 1 -> 1

If you bring up the On Screen Keyboard for VI, does that work?

That’s one of the keyboards that uses Keyman’s default hotkeys (RALT SHIFT K, RALT SHIFT O, RALT SHIFT M). You need to change or turn off those hotkeys in Keyman configuration. It doesn’t sound like what’s causing your problem, but if your user tried those keys then it will get confusing quickly. I’d disable them, then turn Keyman off and on and see if it helps.

FWIW @Lorna, I am right now working on a fix for this conflict (track it at https://github.com/keymanapp/keyman/pull/2360/files).

@hodgsonian, if none of the above helps, can you send a diagnostic report to us following steps at https://help.keyman.com/kb/40?

Thanks. I’ve sent in the diagnostic report (turning off hot keys didn’t solve the issue). However, I have a feeling the issue is something to do with the guy’s computer. The keyboard works fine on other machines. On this machine, even when I remove the VIE keyboard (already available through Windows 10 language settings) then set the input language to English, it still produced V characters. For example, typing a vowel followed by ‘s’ puts a district above the vowel (not v + ‘s’), or when I double tap ‘e’ it produces ‘e’ + diacritic. I think this is the excited behaviour of the VIE keyboard but it’s happening even when I attempt to remove that keyboard and select ENG. Additionally, when I removed VIE, then clicked on input method icon on bottom task bar, ENG and VIE we’re there, VI (Keyman keyboard) was fine, even though it was VIE I removed, not VI. Additionally again, I removed the VIE keyboard yesterday but it reappeared on restart. All this to say, is battening on this particular machine and no others and there are these additional behaviours.

Hi @hodgsonian,

I’m not sure what the VIE keyboard is? But it does sound like it is taking over the keyboard and not allowing Keyman to work as it should. I would hope that if you are able to remove that keyboard, things would work correctly.

According to the diagnostic report, however, Windows is reporting only US English keyboard installed and no Keyman keyboards registered. This may just be because you didn’t have Keyman running at the time you took the report?

The VIE keyboard is what appeared when adding a Vietnamese keyboard through Windows language preferences - but it refused to be deleted properly. I wonder if this had something to do with the set region and system language (but the system language was English). I think Keyman was running. Anyway, I wasn’t able to make typing easier for them but they worked around it. Workshop is finished now and they made a few books and other texts. Thanks for looking into it.

Ian

When I installed the Keyman Vietnamese Basic keyboard (VI), Microsoft’s Vietnamese Basic keyboard (VIE) also appeared in my keyboard list.