Problem accessing Tagmukay font glyphs requiring Right-alt key on Ubuntu Linux 18.04

I have a PC laptop with a US physical keyboard.
My operating system is Ubuntu Linux 18.04
I’m testing Tifinagh typing in LibreOffice with the Tagmukay font chosen
I have Keyman 13 for Linux running loaded and the Tawallammat Tifinagh (SIL) Keyboard activated in ibus and chosen in the dropdown menu.

Characters accessible from the normal keyboard level and with the shift key level work but characters requiring the Right-Alt key level (on my machine AltGr key) don’t seem to work:

  • When I type AltGr-m I don’t get the Tifinagh end-of-sentence marker
  • When I type ⵔ,AltGr+7,ⵜ (erra+AltGR7+etta) no consonant transformation takes place.

I found the solution for the AltGr key not working properly. It was a Linux 18.04 issue regarding the AltGr key. Normal keyboard settings Ubuntu Linux 18.04 did not allow for the needed changes, so in order to make the AltGr key work as needed, I had to do the following:

  1. install gnome-tweaks
  2. open tweaks and go to the menuitem ‘keyboard & mouse’
  3. Next to the “compose key” line click the “disabled” button
  4. In the resultant dialog click the toggle switch to turn compose key function on.
  5. Then select the “Right Super” radio button
  6. close the dialog and tweaks

Now while in LibreOffice writer if I type ⵔ,AltGr+7,ⵜ (erra+AltGR7+etta) the correct transformation takes place, rendering “erta” (oddly though when I do the same in this online text editor it doesn’t work, and even if I copy and paste into this text editor it comes through as ⵔ⵿ⵜ).
Also now I can easily access the end-of-sentence marker with AltGr+m to render ⵰

Hope someone else using Linux finds this solution helpful.