Phantom languages in my Windows language list

I noticed today that my Windows language bar lists 5 language choices, but in Language preferences I only have two set. None of these use Keyman keyboards. I tried uninstalling Keyman then reinstalling it, currently it says there are no Keyman keyboards installed. I realize this sounds more like a Windows issue than a Keyman issue, but do you have any suggestions how to remove these phantom languages?

my language selection list:
image

my language list in settings: ( I have ENG International defined as a keyboard option along with ENG US).

KeymanDiagnostic.tsi (202.0 KB)

After posting this, I did manage to get the Afrikaans to disappear, by first adding it as a Windows language in Settings, then removing it. The same strategy does not get rid of the Hebrew or the Amharic, perhaps because I cannot add one of those languages then choose the US keyboard for it.

Sometimes restarting Windows removes these. We found this happening more in Keyman 13 and earlier, where disabling a Keyman keyboard (or exiting Keyman) would sometimes cause Windows to add the US English keyboard for languages that otherwise would have been removed.

I don’t have a great answer; I sometimes use an unsupported tool I wrote to uninstall the keyboards but not sure if I want to promote using that!

1 Like

Does your tool work by removing keyboard layouts in
Computer\HKEY_CURRENT_USER\Keyboard Layout\Preload ?

I’ve done that and my phantom entries have gone.

1 Like

It has a bunch of techniques because there are many layers to Windows keyboard registration and it’s easy to fall between the cracks in them.