On-Screen unpreditable endless wait, Developer 14 on Windows 10

I see you had a previous report that was fixed by enabling the debugger, which, however, I do have enabled.

I do some coding, get a successful compile, then go to On-Screen > Fill from layout.

It starts up and gives a message like this:
Capture1

“Wait” lasts forever, or at least for more than 3 hours.

Task Manager shows the Developer engine using some memory but using 0% CPU. So, waiting for something, but not in an endless loop.

The message may or may not refer to a line of code that has been changed.

In this particular instance, the line of code was

  • [LALT K_K] > “к̕”

If I remove that line of code, on-screen fills OK. If I change it to

  • [RALT K_K] > “к̕”

it fills OK.

So that’s the problem right?

BUT later on, I get the same problem with message pointing to another line of code.

I take the line out, it fills OK.

I put the line back in, it fills OK.

I have tried:

  • uninstalling and re-installing Developer
  • uninstalling my malware detector, Malwarebytes
  • totally rewriting the keyboard code
  • various other things, increasingly far-fetched.

It goes on happening unpredictably with no pattern that I can see.

My workaround is to just keep trying code changes and un-changes until it works, which so far it has done eventually.

I have actually seen this kind of thing a couple of times in the past, with other software, once on an earlier version of Windows. Those turned out to be problems with memory management.

Microsoft has a tradition of bad memory management (remember the “Blue Screen of Death”?). Some system development tools do their own memory management, wich can also go wrong.

Welcome to the community.

Did you have this option (screenshot below) checked on the OSK?

image

Thanks for the suggestion:) I have tried it and it makes no difference :-\

Can you send the keyboard project over, so I can test it on my side?

I put a zip file of the project on google drive. Here’s the link
https://drive.google.com/drive/folders/1CxI7vJ8Qqlv_G1qwF56zi-nB9u_zEPmM?usp=sharing

I really appreciate the help.

This is an issue we are aware of but had not yet documented. If you have hotkeys set in Keyman Configuration they can conflict with the import for some configurations. I have just documented this for resolution.

The workaround is to clear all hotkeys in Keyman Configuration / Hotkeys tab, before clicking “Fill from Layout”.

(If the dialog appears and stays visible for more than a couple of seconds, you can close it with the X button on the top right of the title bar.)

Thanks.

I really want to keep the hotkeys for display menu and display keyboard. I will do that and hope it does not cause a problem.

I would suggest removing the hotkeys and restoring them after you have run the import (it is likely that the Alt+Shift+K and Alt+Shift+M hotkeys will conflict)