Newest Keyman disengages language keyboard


#1

Hello Keyman Support. I just finished a five-day class for Cheyenne language speakers. The class was on technology to support their language development. On Thursday we had students install and practice using Keyman. Timing was perfect since you announced the free version available the preceding day.

I need to report a problem each student encountered with the version posted now on the Keyman website, 9.0: The Cheyenne keyboard would not stay active whenever they would begin to use a different programs, such as changing from Lexique Pro to Microsoft Word. I recall having this issue myself a number of years ago, but then it was solved for the paid version 9.0 I currently use on my own computer.

I tried to find the setting in the students’ Keyman so that their Cheyenne keyboard would stay enabled as long as they desired but I was unable to find that setting. Perhaps I missed it during the pressure of trying to keep the class going.

I don’t know if it makes any difference, but I discovered that all the computers in the computer labs at the tribal college where I was teaching are still using Windows 7. My own computers run under Windows 10.

Is there any way that we can change a setting for the student computers so that the Cheyenne keyboard will stay enabled as long as each user desires, regardless of whether the user changes to a different program?

I am back home now from the tribal location, but if there is a simple setting change I can try to communicate that to someone back there so they can make the change.

Thank you,
Wayne


#2

Recent versions of Windows, by default, switch the active keyboard for all applications, so Keyman does not control this setting on those computers – including yours.

Windows 7 kept the language switch separate and did not activate for each app. You should be able to use the option in Keyman Configuration “Select keyboard layout for all applications” to control this for Keyman 9.


#3

Thank you, Marc. If I understand your response, our experience is the
opposite. A technician from the tribal college worked with us. He tried
changing the setting on the Windows 7 computers so it would work in all
applications. But it did not. But Keyman 9.0 does keep its keyboard enabled
in all applications on my Windows 10 computers which is a big help to me
since I use quite a few programs.

I do have an issue under Windows 10 that I did not have under previous
versions of Windows. I emailed you about this several months ago: After
some time of Keyman having the Cheyenne keyboard enabled Keyman causes
keyboard entry to fail. To regain keyboard function I either have to reboot
my computer or exit Keyman then enter it again.

Thank you very much for keeping Keyman going,
Wayne


#4

Do you know which release of Keyman 9 was being used on those Windows 7 computers?

In terms of the other issue you reported, I think it may be resolved with Keyman 10, which is available in pre-release form if you want to test it, at https://keyman.com/beta/


#5

Yes, the latest version of 9.0. The students downloaded it from the Keyman website the day after you announced that it would be a free download.

Thanks for the info on Keyman 10 beta. I will probably try it.


#6

There are Alpha and Stable versions available from the link you gave but no Beta versions.


#7

Keyman 10 is in Alpha release – not yet in Beta. We should probably rename
the /beta page to /prerelease to avoid that confusion.


#8

Thank you. I installed the Alpha release and so far it is working fine, no more stuck memory issue. I have used it long enough to be a good test. Thank you to the entire Keyman team for all your good work.


#9

That’s great feedback, thank you!


#10

I have the same problem of Windows disengaging the selected language keyboard whenever I switch to a different application. I have tried Keyman versions 8.0.631, 9.0.472, and 9.0.528 – the problem was the same in all of them. 10. 0.934 alpha failed to install. Win 7 x64 sp1.


#11

@Scott_Youngman, is this issue resolved with the option I mentioned above, “Select keyboard layout for all applications”, in Keyman Configuration?

Note: Windows 7 kept the language switch separate and did not activate for each app.


#12

Now that’s interesting … I had “Select keyboard layout for all applications” enabled (checked) for all versions I tried, and the problem continued. But just now I disabled it, tested among several applications, then reenabled it. Problem resolved! Thanks.


#13

Glad to hear that you were able to resolve the issue! Thanks for letting us know.


#14

I just installed the SIL IPA Unicode keyboard (which also installed Icelandic as a new language on my system). When that is the active keyboard, it disengages when switching between applications. My three other keyboards – EuroLatin, Galaxie Greek, and Galaxie Hebrew – continue to work correctly when they are the active keyboard; the disengagement problem occurs only with SIL IPA.


#15

The Hebrew and Greek Unicode Transliteration keyboard has the same problem of disengaging when switching to a different application.

Editː I just discovered what is causing the problem. The keyboards do not disengage if I switch applications by clicking on their taskbar icons; they disengage only when switching with Alt-Tab. However, my Alt-Tab is handled through a utility called Vista Switcher instead of the default Windows Alt-Tab dialog. When I disable Vista Switcher and use Windows Alt-Tab, the problem disappears.

I don’t know why only some keyboards exhibit the problem and others work fine. I will stop using Vista Switcher.


#16

That’s great research: I’m not sure we’d have ever pinned it down from here! And helpful information to know. It’s possible that Vista Switcher is trying to do some language switching itself and doesn’t support custom input methods? It looks like a nice app though :slight_smile:


#17

Very interesting … I hadn’t done a Windows 7 update in about a year, and thereby violated one of the basic rules of troubleshooting. Now that I’ve finally brought my system up to date, this problem has disappeared; keyboards no longer disengage with Vista Switcher. I apologize.


#18

No worries, glad you’ve resolved the problem to your satisfaction.