Longpress key does not print the character

Hi, sorry to bother you again. I got stuck with another problem while creating my touch keyboard. I created longpress popups for three keys on the shift layer that won’t work when I run the debugger in the local browser. I even tried installing the keyboard into my phone and the problem remains. The character does appear when I keep the key pressed but it won’t type anything when tapped. I do not know where the problem could be because this one is the third longpress popup for the key and the others do work (É works perfectly). The code assigned to the popup is T_0246_0301, code that I have defined in the layout interface with + [T_0246_0301] > U+0246 U+0301.
q1
q2
I have the exact same problem with two other keys from the shift layer that follow the same pattern. However I find this strange becuase I coded the same three letters in their lowercase version into the default layer. For example, for the one I said above I used the code T_0247_0301, which is also defined in layout the same way as you can see in the image, and this character does appear when I test the key in the debugger. It would be great if someone could help me. Thank you for your support.

Ok, I solved it. I think I was having the problem explained in this post Keyman key partially works - #8 by leepartridge

I had to add SHIFT before the T code because that was the layer in which the key was.
I wrote, for example, [SHIFT T_0246_0301] > U+0246 U+0301 and the issue disappeared.

Good work on solving this :slight_smile: I’m sorry it’s taking me so long to respond – I am somewhat buried in messages!

1 Like