Letters in newly built keyboard doesn't ligature

I made my own phonetic Farsi keyboard using Keyman Developer 11 for Windows 10…When I chose the keyboard under the Language Preferences Bar, all the keys I depress display right, but letters don’t ligatuter. This is my first attempt to use the Keyman Developer, and I am not happy with the Keyman’s own Persian “Phonetic” Keyboard which is mediocre. I need your experience to help me out.

I guess you may have a font issue. Can you try this font and see if it works?

https://software.sil.org/scheherazade/

First, thank you for taking the time replying. I’m grateful.
I installed the Scherzadeand font then chose my keyboard. The same result. The individual keys correspond fine, however, ligaturing doesn’t take place. I plan to read the manual again and see if I can resolve the issue. My hope is to make this keyboard and put it on Keyman for public use. Thank you again, Makara.

Did you select the box on Keyman that says this is a right-to-left keyboard?

I’ve tried a quick test and don’t see the problem.
The link below has a simple Keyman keyboard. Press ‘p’ for peh, press ‘t’ for teh, and press ‘b’ for beh. This test file doesn’t have any other Farsi characters.

پتب
پ ت ب
the second line I separated the three characters with a space, in the first line they are joining together fine. If you install my keyboard into Keyman, do you get peh, beh and teh joining together?

(The folder also includes my source file.

https://drive.google.com/drive/folders/1DAny3J00B8ajduGdvHqvOUb85GHAWbjF?usp=sharing

Thanks, Lorna. If you mean the left-to-right in Microsoft Word, yes, I did. In the Keyman, Premium or Developer, at the expense of sounding massively ignorant, I don’t see the option!?
Thank you again.

Steve, thank you for your care. I downloaded Farsi Test, compiled and selected it to write the string. and could produce the string in Word. I need your permission to send you my keyboard source for fault-finding. I have less-than-a-couple-of-hours expertise in the Keyman Developer. Pushing my luck, awaiting your reply.

Make sure this box under "Message: is ticked:
image

Note that the right to left box is only relevant for KeymanWeb.

Lorna, I intend to use my keyboard on the desktop (Windows). When all gets ironed out, that too. The persisting problem is the desktop, and my lack of experince! Thanks to the Community, I seem to dig a bit every day😊

Steve, new users (such as me) cannot send files to SIL…

I’ve upgraded your membership level so hope you can now share files here.

Thanks for the privilege. Thank you.

This me be a duplicate. Sending it from home… The keyboard I’m trying is attached: phofarsi.kmn (1.3 KB) . With advance kudos.

I see what the problem is. In your keyboard you have used many characters from the “Presentation forms” blocks of Arabic characters. These are designed never to combine.

For instance in your top row of letter keys, the characters you’ve put for the q and w keys look fine. But the “e” key outputs U+FEC9 ARABIC_LETTER_AIN_ISOLATED_FORM.

If you change that to U+0639 ‘ARABIC_LETTER_AIN’, that will give you a form that will combine when next to other combining Arabic letters.

If you review your file and look for anything that the Unicode character value starts with “FC” or "FD or “FE” , those are more presentation forms. Normal Arabic/Farsi character values start with “06” or “07” or a few with “08”.

A huge thank-you from a faithful student to a kind, competent teacher. I would never have learned this much from Keyman Dev without your help. Based on the offered guidelines, I will try again and post progress. Words fail me to express my gratitude, Steve.