Language selection setup

Dear Bloom friends, I have done several vernacular bloom books by now. Under settings, I have the first box for vernacular, second box for national language and then I have English on the back 1-2 pages. I want to have some other Bloom books that are only in the national language. Can I do this and have the second group of bloom books (that are only in the national language) mixed in with my original collection of bloom books that are in 3 languages?

Hi Craig–the language choices apply to all the books in a collection. So if some books are vernacular books and others are national language only, they will need to be in separate collections.

It’s very easy to switch from one language to two or three as long as the books use the same vernacular language…just turn the second and third languages on and off using the “One language” control in the top center in Edit tab. But it does apply to the whole collection, so if you mix monolingual and trilingual books in one collection you’ll have to pick the right setting as you open each book.

I see that. Now, what happens if I’ve already finished a book in the national language and it’s in my vernacular collection? I’d prefer not to upload it to the website with the vernacular attached, since I do intend to have a separate vernacular version as well. Is there a way to move the book?

Hi Mackenzie. You can temporarily select the national languages as Language 1 in your collection so that it is the primary language when you upload. When you choose the “Share on the web” publishing option, Bloom should have check boxes for all of the languages in the book. Select only the language or languages you want to upload. That way you can upload just the national language and exclude the vernacular from the upload.

Thanks! I forgot about changing the language settings at the collection level. However, now my problem is, when I change the settings, the text of my already-written book moves to the little speech bubbles on the side. I’ve never been able to copy and paste from the speech bubbles. Any tips on how to not have to re-type my whole book? ETA: Or I suppose it doesn’t matter quite as much if I’m only trying to upload the book for others’ use, as long as the text is there in some form. I’ll ponder that. Thanks!

It is actually possible to select text in the bubbles to the side now.

However, if you’ve got text that you need to move from one language to another, the best thing is to make the new language Language 1 and the existing language Language 2. Then enable both languages with the language chooser in edit mode:
Then you will have two text boxes. Select and cut the text from where it doesn’t belong and paste where it does belong.
Feel free to write me separately if you’d like:

This sounds good. However, in practice, enabling two languages in
a large-print children’s book that is designed for only one
language causes overfilled text boxes for both languages, so that
I can’t see what I am cutting/pasting. I could temporarily set a
smaller font size to the boxes before pasting from L2 into L1
boxes, but this introduces editing complexity and potential
formatting errors if I forget to resize the text after I’m done,
or if I reset it to a different size than it was. Or I could drag
a picture frame smaller to be able to view the text, but this has
similar issues.

  I am very happy with the new copy-from-bubble feature in Bloom.

Thank you, team!

Kim Blewett

Language Technology Consultant


I was about to happily report that I can, in fact, copy from the speech bubbles now, which would solve my issue (as I currently have national language text labeled as the colloquial language, but don’t want to upload it that way). But as it turns out, I could only do it from my cover page, none of the others. Any ideas? Using 4.7.106, editing the “About Coronavirus” comic book.

You’re right. In comic-style books, the translation in other languages bubbles disappear when you try to click on them. You could use the “Suggest a feature” thingy in the Bloom Help menu to suggest that the other translation bubbles stay put until you click outside the box and outside the bubble.

Another work-around I’ve used is to create a PDF of the book then copy and paste from the PDF

Ah, well, it’s good to know it wasn’t just me or my computer! I’ll suggest the feature, and see what happens with the PDF idea. Thanks for your help!

ETA: Alas, copying from the PDF isn’t working. The font loses half of its vowels, which would make it just as “easy” as retyping all the text from the speech bubbles.