Language accidentally omitted from new project

When creating a new project in Keyman, we forgot to put in the language name and then hit OK. We looked and looked and couldn’t find anywhere in Keyman to enter the language codes again.

The response we received from the dev team was:

The Project Template dialog creates a bunch of files. Once they are created, you cannot go back and change the preferences there – instead you have to change the final files. The language settings are stored in the package .kps file and the .keyboard_info metadata file.

No question here, although I’d like to see this editable in Keyman Dev. I’m just reporting this for other people’s benefit.

Thanks for the feedback. Once the files have been created, they can easily diverge from what we would easily be able to edit in a templated way, so we haven’t tried to make this editable.

I would like to see this fixed in the documentation at least; we welcome pull requests to (I understand that this is probably too big an ask!)