Keyman will not install

Using macOS Monterey, Version 12.0.1. When I click on Install Keyman, I get the error message “No such text input source: Keyman (1).” Another member had the same problem in December 2021. You solved his problem with an updated version of Keyman … but I am using the version that he said solved his problem, and yet I am getting the same error message.

What version of Keyman is this you are having the issue with? Is it with the latest stable version Keyman 14.0 for macOS?

Thanks for getting back to me so quickly! Keyman-14.0.283

Here is what our developer suggests would help.

I’m guessing that that there is something existing from a previous install that it is having a hard time replacing on disk. So maybe cleaning up manually, deleting the previous version from the Input Methods folder, would help.

Open Finder and go to /Users/[userName]/Library/Input Methods and delete Keyman.app

If it can’t be deleted because it’s in use, then might need to disable in System Preferences first and possibly restart the Mac before deleting

I cannot explain why or how, but the problem is solved. I looked everywhere for the Keyman.app on my hard drive, and it was no where to be found. It was not in the Input Methods folder, or anywhere else. The only mention of Keyman on my computer was the dmg package (that would not install) in my Downloads folder. So I trashed that, emptied the trash, and downloaded it again directly from the SIL site. I tried it again, and this time it installed, no problem. Mystery!, but problem solved. Thanks.

Was this the first time ever you clicked to install Keyman on the machine in question? Just trying to understand the mystery.

Yes. This is the first time I downloaded the Keyman software. I tried multiple times to install it. Finally, I gave up and read your earlier comments, including from the person in December who had had the exact same problem. After that, I went back, erased the download from my folder and went to the site to which you had directed the other inquirer (which was the same site I had originally used before.) I downloaded the app afresh, and got the same error response. That’s when I contacted you.

1 Like

Tracking this at https://github.com/keymanapp/keyman/issues/5578