Keyman (or other?) typing odd quotation characters

I received a question from a user and I’m not sure where to go with it. I’ll post the question below, and then further discussion they’ve had.

The problem is that quotation marks and apostrophes don’t work properly when using the Keyman keyboard for the Tiaang language. For example, I‘m now typing with my Tiaang keyboard, and you can see that the apostrophe in < I‘m > looks like a single opening quote mark instead of an apostrophe. Here‘s what „double quotation marks“ look like, opening and closing. It‘s really annoying to have to switch back and forth between the English and Tiaang keyboards every time I come to an apostrophe or quotation mark, so would you be able to help me fix this issue? (Might it have something to do with the fact that we used the Icelandic keyboard as a basis for the Tiaang one?) I’ve attached what I think are the relevant files, but let me know if you need anything else.

From @BlewKi,

Your Tiaang.kmn file does not include any instructions regarding quote marks, so the European marks are coming from somewhere else. Could be from Word’s or LO Writer’s smart quotes following the Icelandic layout, I suppose.

I have added a section to Tiaang2021.kmn that gives a “rota” effect to the ’ and " keystrokes. That is, type [’] for a straight quote mark. Type [’] again and it changes to an open single quote [‘]. Type [’] a third time and ‘ changes to close single quote [’]. Type a fourth [’] and it changes back to the original straight quote mark. Same for ["] double quotes. This should override any smart quotes settings related to the base language, but see point 6 below if you are having problems in Word or Writer.

On a Windows laptop this new Tiaang2021.kmn file needs to be “compiled” into a kmx file. I am not set up right now to do this job, and since we’re focusing on getting back to PNG I can’t do this right now. So I’m including James Post on this message—James, can you help Rebekah by compiling Tiaang2021 and testing it with the Icelandic base? Files here here: Tiaang - Google Drive

I haven’t actually seen this problem before—“funny” European-style quote marks appearing with a Keyman file. We used to assign Keyman layouts to Icelandic also, back in the day, but various computer programs did not use “smart quotes” in those days either. So I’m wondering if there’s something else going on. Here are a few questions that might help James or me figure out your problem.

  1. Does this happen everywhere on the computer—whether you’re typing in Paratext, FLEx, Bloom, Word/Writer, etc? Or just in some programs?

  2. On every computer that has Keyman Tiaang installed or just on one/some of them? Windows, Wasta?

  3. Does it happen only when the Tiaang keyboard is active (I assume so, but just checking)?

  4. If it happens in Word or LO Writer, can you get into Settings and see what the autocorrect rules are for quotation marks? In Writer this is found under Tools > Autocorrect > Autocorrect Options > Localized Options. You can turn smart quotes on/off with the checkbox toward the bottom of this window, and you can specify which characters to use in the boxes below that. If you see the open quote below the baseline here you can change it and the other entries.

  5. However, before you manually change these quote mark entries, it’s possible that a setting somewhere else in the program is specified “Icelandic.” There are a couple of places where this might be recorded. I can’t guide you to them in Word because I haven’t used it for many years, but in Writer you can check here.

  6. (Writer) Check Tools > Options > Language Settings > Languages. You should probably NOT use Icelandic as the Default Language For Documents here. If it is, change to English. (Writer in Windows might have Options under the Edit menu rather than Tools menu.)
    —(Writer) Check Tools > Options > Language Settings > Languages. You should probably NOT use Icelandic as the Default Language For Documents here. If it is, change to English. (Writer in Windows might have Options under the Edit menu rather than Tools menu.)
    —Check the Default Style definition. In Writer go to Styles > Manage Styles. This should bring up a list of all Styles at the right of the screen. Select “Default Style” and right-click. Choose Modify. Click the Font tab. Below the Family list you should see a dropdown box “Language”. The language should be either “English” or “(None)”, which is at the top of the list. This setting determines spellchecking and autocorrect rules. You’ll find something similar in MS Word style definitions.

  7. Even if you change the “language” to English or “none”, you might need to reset the smart quote rules as in 4. Here’s a list of the correct “normal for our purposes” curly quotes with their Unicode code points, so you can copy/paste the characters if you can’t type them directly.

Single quotes
Start: ‘ U+2018
End: ’ U+2019

Double quotes:
Start: “ U+201C
End: ” U+201

  1. Paratext has its own “special character typing” solution: You can define an autocorrect.txt file and place it in the project folder. If you see this file in your Tiaang PT project folder, send it along and we can check it out or add smart quote rules to it. Autocorrect in PT is useful because it is sent/received with the project, so anyone who has the project (users on a temporary computer, consultants, admins, etc) can type the language in Paratext with no further configuration. All the Boug projects have the file, which contains smart quote rules as well as accented vowels, engs, glottals. I have not seen a case where autocorrect.txt and Keyman conflict, but I suppose it’s possible.

I hope this isn’t too much information for one email. Write back to James and me with the answers to questions 1-5 at least. We can help you further if needed.

Blessings,

Kim

From the user,

Here are the answers to Kim’s questions (the ones I can answer):

  1. On my computer, it happens in Outlook and Word. In Paratext, I always get straight quotes unless I use < and > to get curly ones in the appropriate direction; that seems to be working fine. Bloom and FLEx seem to just give me straight quotes all the time, unless I copy and paste the text from another source, such as Word.
  2. It’s doing the same thing on Jessie’s computer in the Office programs (Outlook, Word). She felt like it happened more randomly, sometimes it worked fine and sometimes it didn’t, but she can’t be sure if that’s just because she was using the keyboard in different programs. We also have four Wasta laptops, but they’re currently at CTS; we haven’t yet had the opportunity to try the Tiaang keyboard on them.
  3. Yes, it only happens when the Tiaang keyboard is active.
  4. In MS Word, Autocorrect Options has two tabs, “AutoFormat As You Type” and “AutoFormat.” The former has a list “Replace as you Type,” with “Straight quotes with smart quotes” ticked as one of the options. When I untick it, it doesn’t give me any other characters I can use. Under the “AutoFormat” tab, there is a list “Replace,” which also has an option “Straight quotes with smart quotes” ticked. It also doesn’t give me alternative characters that could be used.

Thanks for your time.

I (James) am also not setup to compile keyboards at this time, and haven’t done so for several years.

Any help/suggestions would be appreciated. I thought by posting here, somebody might have experienced something similar and have suggestions.

It does appear that the user is using MS Office and not LibreOffice. Though they haven’t been able to test this on a Wasta laptop for their co-workers.

Thanks!

James

It does seem this may be coming from the Icelandic keyboard. I found this on Wikipedia:

image

I don’t know how to recompile the Keyman keyboard to use a different base language. Can we just use an English language for a base now?

The problem here is that the .kmx doesn’t come with a language tag. After installing it, the keyboard will be associated with the Windows’ default keyboard. Here is what I see when installing the file with ISL keyboard set as the default language.

What you actually want is to have for the keyboard to work is to add tbj to the keyboard using the Add language orange button. Then remove the other one.

One thing though, if you keep using your .kmx you have to ensure that the right associated language is set for the keyboard each time you install it on a computer with Icelandic or any language other than US English.

Here is a keyboard package of the keyboard with the correct language. Each time, it’s installed, it should work correctly right off even though you are using a default language other than EN.

tiaang.kmp (2.7 KB)

Here is the keyboard project for your future use: tiaang.zip (9.7 KB)

It looks like this is resolved.
Some background: The Microsoft version of the SIL IPA keyboard uses Icelandic as the default language (you can’t add an unsupported language using MSKLC). This wasn’t a problem when Windows knew nothing about Icelandic syntax, but now Windows has a locale for Icelandic which leads your text editor to use the “Icelandic” quotes. Unless the user is actually Icelandic, It is possible that the user was typing in IPA using the Microsoft keyboard, and then switched to the Tiaang Keyman keyboard in the same document.

1 Like

Actually there are ways of working with unsupported languages with MSKLC. But it’s not guaranteed to be future proofed. But since I usually just use Keyman, I don’t tend to bother.

Michael Kaplan’s old blog had useful examples.

I uninstalled the .kmx file and installed your .kmp file instead. Now the quotes are working fine, but I’ve lost all the accented vowel marks that were in there before (which was the whole purpose of having a Tiaang keyboard).

I’m not sure what is going on, but if you have correctly installed the .kmp; whatever you have as the “default keyboard” on Windows or Keyman’s “base keyboard” is irrelevant. The “Tiaang” keyboard version 1.1 should output those special character configured.

i.e.
;+a > á
;+Shifta > Á

  1. Can you confirm that the keyboard installed is Tiaang version 1.1?
  2. What application are you using when you try and use Tiaang keyboard?
  3. What is your Keyman version? Windows version?

The more you can tell above how this happens, the better support you’ll get.

If the problem persists, can you send a diagnostic report over using the instructions here: https://help.keyman.com/knowledge-base/40.

Well, I seem to have solved the problem by uninstalling the .kmp file, reinstalling the original .kmx file, and then just manually changing the language tag as you showed in the screen shots of your original reply. It’s probably not worth trying to troubleshoot the .kmp file anymore at this point. But thanks very much for your help!
Rebekah

If you are using an older version of Keyman, you may want to try and latest stable version at Keyman for Windows 14.0. I’ve tried it on my side and it’s installed successfully and there is no issue with typing ;+a to get “á” and the rest.

Here is what should be seen after installing the .kmp without having to bother changing the language tag.
image

Note that the version I’m using is Keyman 14.0.281. If you are using it too, but it doesn’t work as described here. Please send Keyman a diagnostic report so that it can be examined further.

Hmm, well here’s another issue: I’ve just installed Keyman 14.0.282. But both before and after I installed this version, I can’t seem to open the app. When I double click on the icon, nothing happens. When I installed it and it gave me some sort of welcome screen, I clicked on the button to open Keyman, the welcome screen went away, and nothing happened. I can access the configuration screen, but that’s it. I’ve never seen a screen like the one in your screen shot above. I’m using Windows 10. Maybe none of this matters, because the keyboard is working fine now anyway, but I thought this was strange.