Keyman Onboard incorrectly shows Latin keyboard, prints Latin chars

Ubuntu 20.04.4 LTS
Keyman for Linux 14.0
Keyman-Onboard 1.4.2
Shavian Imperial 1.1 (keyboard layout)

Problem

Keyman with Shavian Imperial keyboard does not show the Shavian characters on the key caps. The displayed keyboard is just the onboard standard vanilla keyboard with Latin key caps that does not produce Shavian characters, just Latin characters. However, the Keyman Configuration dialogue shows that the Imperial keyboard is installed and active and clicking Help displays the cheat sheet for the Shavian phoneme characters for English.

Evidence of bug?

During installation an error is thrown; not being a programmer I don’t know what it means (see terminal shot below).

Launching Synaptic, I selected the onboard-keyman, onboard-keyman-common, and onboard-keyman-data packages, all Ubuntu version 1.4.2+onboard1.4.1-5.0~focal, for installation.

Can anybody advise what is wrong and how to go about remedying the problem?

Regards,
Hedley

When you said the Shavian keyboard is active, do you see a little dot next to the keyboard name from the dropdown menu as shown below?

No, I don’t see either of the English (Shaw Imperial) or English (Shaw QWERTY) options on the input-selector drop down. The Keyman Configuration app shows both keyboard layouts are installed. (By the way, I like your nifty key black keyboard; I just get a plain, possibly default, keyboard of white keys on a pale blue background that completely covers the bottom third of my screen, side to side.

Inadvertently sent start of message. How do I get the two Shaw options to appear on the input device selector drop down. When I become more practised I would like to use a hardware keyboard to type Shavian.

If the keyboard doesn’t appear in the dropdown list,

  • open a terminal window and run ps -C ibus-daemon -f. Paste the output in the reply (this is for a developer to check if the keyboards still don’t appear in the dropdown).
  • then reboot
  • and check the dropdown again