Keyman not typing anything in search box for Adobe Reader DC


#1

I cannot get Keyman to type any characters at all in the search box for Adobe Reader DC. I tried 3 different custom keyboards and none of them would type any characters (special characters or “regular” characters). All 3 of these custom keyboards work fine in other applications.

Another user is reporting a similar (perhaps the same) problem.

I’m not sure if this is a Keyman bug or an Adobe bug.

Windows 7 SP1
Keyman Desktop 10.0.1205.0
Adobe Reader DC 2018.011.20058

James

P.S. Is this the right place to report a bug like this?


#2

Yes, this is the right place to report.

This is a known compatibility issue with Adobe Reader. Adobe Reader by default runs in a protected mode which locks down the process to try and prevent malware embedded in PDFs from impacting your system. This however means that other applications such as Keyman are unable to interact with it. You can turn off protected mode in Adobe Reader configuration (but consequences are your responsibility if you open a dodgy PDF!): Edit/Preferences, Security (Enhanced), uncheck “Enable Protected Mode at startup”.

Keyman 11 (currently in alpha release) includes an additional security module to allow integration with protected mode apps. I have just run a test with Adobe Reader and Keyman 11 and it does work while protected mode is enabled. Keyman 11 is not yet ready for general consumption, however; release is targeted for February 2019.


#3

Ok, that’s one problem solved. Now we can type vernacular in the Search Box. Thank you!

The next issue is this:

Adobe Reader doesn’t differentiate between “ô” and “o”, or “ê” and “e”.

When I am looking fo “tô” in the Tami vernacular examples, it is taking me to all the occurrences of “to” in the English commentary. When I search for “ô”, if finds every word with an “o” in it.

Here’s an example PDF: https://drive.google.com/file/d/1zGsrjxgvL8_B4bOjzY171NPpjAM5W-DX/view?usp=sharing

Also, because of the lack of differentiation, it will return some really weird search results (like below, where it spans a comma):

We have found that Foxit Reader works fine, but I think they would prefer to use Adobe if possible.

Thanks,

James


#4

This is a feature of Adobe Reader, rather than anything specific to Keyman: you can change the search preferences in Adobe Reader, Edit/Preferences, Search tab, turn off ‘Ignore Diacritics and Accents’.


#5

Thank you! That fixed it.

James