Keyman Linux dependency errors

For the last month or two I have been getting errors every time a keyman component gets updated in a number of Wasta 20.04 computers that I maintain. The relevant lines from the Synaptic pkg mgr log are copied below. This has persisted over several new package updates. It’s a “dependency problem, can not configure” error.

I’ve tried purging keyman and all its dependencies and recommends, making sure the files in my home config, etc are gone before reinstalling from freshly downloaded packages. I’m not sure where to look for any control files that might be corrupted. But I don’t understand what could have caused the same error on at least 6 Lenovo laptops that all have the same version of Wasta installed.

Can someone take a look at this log file and perhaps suggest something I can try, or ask for specific further information from my system if needed?

Thank you very much!

----------------------Synaptic Log file from today:------------------

Setting up libkmnkbp0-0:amd64 (15.0.265-1~sil1~focal) …
Setting up ibus-keyman (15.0.265-1~sil1~focal) …
error: user name does not exist

dpkg: error processing package keyman (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3-keyman-config:
python3-keyman-config depends on keyman-engine; however:
Package keyman-engine is not installed.
Package ibus-keyman which provides keyman-engine is not configured yet.

dpkg: error processing package python3-keyman-config (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
ibus-keyman
keyman
python3-keyman-config

I’m also using Wasta on a Lenovo machine (X260), and I get recurring errors when I try to update software… I haven’t dug as deep as kblewett (i.e., I didn’t know Keyman was the issue), but would love a solution. Any recommendations for – or against – just removing Keyman? I don’t use it.

@EberhardBeilharz any suggestions here?

This looks like a bug in the post-install script of ibus-keyman. I created issue #6893 to track this. A fix is on the way…

1 Like

A fix will be included in Keyman 15.0.266 and 16.0.26.

Thank you, Eberhard and others!

This bug also occurs on my HP Pavilion All-in-One 24-xa0xxx running Linux Mint 20.3 Cinnamon. I’m pleased to wait the fix on the next Keyman version.

=== log report: ===
E: ibus-keyman: installed ibus-keyman package post-installation script subprocess returned error exit status 1
E: keyman: dependency problems - leaving unconfigured
E: python3-keyman-config: dependency problems - leaving unconfigured

My Wasta 20.04 system upgraded to Keyman 15.0.266-1 yesterday (along witih all available updates), but I am still getting the error. Do I need to reset something to get it configured?

Sorry that it’s still not working. I can’t reproduce the problem, so it’s hard to test that any change will fix it…

@kblewett Can you please send me a message or email and attach the following files: /var/log/dpkg.log, /var/log/apt/history.log and /var/log/apt/term.log? Maybe that sheds some light what’s still going wrong. Thanks!

Keyman 15.0.267 and 16.0.36 will contain another attempt to fix this… :smile: