Keyman Developer: "Test keyboard" command behaves oddly

If I create a new keyboard an add some code, if I try to test my keyboard with “Test keyboard” in the keyboard menu, I get an error message that Keyman Developer was not properly installed (code 0x00000). If I start the debugger, that works and I can test my keyboard. And once I have started the debugger, Test Keyboard will work on that keyboard from then on.

Once testing this I got a dialog that Keyman Developer had a problem and needed to close. It could not submit the report because Windows defender reported a virus in the temp file.
image
I’ve attached the tsi it could not submit. tkd6607.tsi (290.1 KB)

I have Keyman Developer and Keyman Desktop 13.0.115.0

Hi Steve,

I think we’ve addressed the Test Keyboard issue with Keyman Developer 14 / Keyman 14 beta. Would you be willing to try with the beta version downloadable at https://keyman.com/beta

I tried 14 beta (14.0.235) and I still get a confusing error message instead of a prompt to compile the keyboard when I enter some rules in a new keyboard file and save it.

image

I’m not sure what is going on here – it sounds like we may have to do some deeper debugging to trace the cause.

  • If you use F5 to run the debug mode, does that always work?
  • Is Keyman running before you start Keyman Developer?
  • As well as answering those questions, can you also capture an debug log which may provide more detail please? https://help.keyman.com/knowledge-base/76