Keyman Developer debug fails

When I go to debug a keyboard, Keyman Developer says “Unable to start debugging – failed to switch to language with error 80004005”.

I have Keyman Developer 10.0.1098.0

Maybe I just figured out my problem. In Keyman configuration, I had the Keyman Developer Debug Host Keyboard unchecked. I checked it, and the debugger now works.

After I was working for a while, I saw a different error. “Unable to start debugger – please make sure Keyman Developer is correctly installed (the error code was 00000000).”

It turned out this was because I had a typo in my keyboard code and the keyboard would not compile. I’d suggest a more specific error message, such as “Error, your keyboard failed to compile.”

I’d also suggest having the developer beep and display a popup when the compiler fails. I hadn’t noticed it was failing to compile because the error message in the messages window was not prominent enough.

I’d suggest a more specific error message, such as “Error, your keyboard failed to compile.”

As of Keyman Developer 10.0.1094.0, if the keyboard fails to compile and you attempt to “Start Debugging”, you should have seen this popup message:

 "The keyboard did not compile successfully. Unable to start debugger."

Reference: PR #900

But I went to “Keyboard > Test Keyboard” rather than start debugging. I see the popup you mention when I do start debugging. I’d recommend putting that same popup when someone starts to test a keyboard that failed to compile.

Okay, I understand. I almost always press F5 to start the debugger, which gives all the same functionality as Test Keyboard, plus a bunch of deep debugging tools which are really handy. So I missed this. I’ll note it as an additional issue (not sure if we’ll get to it for 10.0 stable). https://github.com/keymanapp/keyman/issues/963

Hi, I also have the same problem recently. I have the same popup either by pressing Start Debugging or Test Keyboard. But if I install it (F9), it doesn’t have a problem. So the code is fine, I think.

Also, I couldn’t find “Keyman Developer Debug Host Keyboard” that was mentioned in the first reply in my configuration.

Keyman Developer 10.0.1206.0

Hi @Marc_Keyman,

I took the Keyman course earlier thi year and I’m now working on finishing my first keyboard. I keep running into the same bug described above: whenever I launch the Test Keyboard function from the Keyboard menu on the File bar, I get the following message:

Unable to start debugger - please make sure that Keyman Developer is correctly installed (the error code was 00000000)

I tried your workaround by launching the ful Debugger mode and that seems to solve it (for now, at least.)

@Manuel_Locria can you advise which version of Keyman Developer you are using?

1 Like

Hey @Marc_Keyman! The bug was fixed apparently. With the new version this is solved. Apologies for the delay in getting back to you!

1 Like

Good to hear! Thanks for letting us know :slight_smile:

1 Like

Pleasure, mate. The last few updates have been great, good work!

1 Like