Keyman Developer 13 Installation Error in Windows 7 64 bit

Can any one face this problem.
When I install keyman developer 13 it allways says "Internet Explorer 5.5 or later is required to install keyman developer."
but i have already windows 7 sp1 64 bit with internet explorer by deafult 8.0
then why keyman developer says above msg.
Is the keyman developer only use in windows 8 or latter windows 10.

We would recommend that you update your Windows and reinstall Keyman Developer.

Let us know if the problem persists.