Keyman Developer 10.0.1098 didn't install until I uninstalled the older version first


#1

I tried at least three times, the installer would start, it would ask me for an administrative login, and then nothing else would happen. I tried several times, the first time clicking the “update now” in the notification that there was a new version; the second time I went and downloaded the update file myself from the Keyman website, then the third time I logged in to my administrative account then tried to run the installer. Each time nothing happened.

Finally I uninstalled the version I had, ran the installer again and this time it worked. My older version was 10.0.1092.


#2

I had a similar issue. I didn’t uninstall the older version, but I tried rebooting. Then when I downloaded the new installer (rather than doing an update through Keyman Developer) my antivirus wanted to quarantine it. Once I got past that it installed fine.


#3

Thanks for the feedback. We’ll keep an eye on it. If this happens again, it would be worth capturing the setup diagnostic logs from %AppData%\Keyman\Diag.


#4

So I repeated the experience. I uninstalled Keyman desktop, installed Keyman Desktop 10.0.1092, then ran the 1098 installer. It did say after some time that I needed to restart the computer and it would then continue, but when I restarted, nothing else happened. Nothing was written to appdata\Remote\Keyman\diags either.

But today’s version, .1099 doesn’t have this same problem. 1092 said there was an update, I clicked “Download now” and the .1099 update did install. Although it was sluggish enough I wondered if it would do the same thing, and was looking in Task Manager and saw that the Keyman updater was running, then the computer said I should restart.