Keyman behaving badly, Win10

It is not working properly, it was working but as soon as I uninstall one Hindi keyboard, my Heidelberg input solution Keyboards stopped working. Then after restarting the PC, the Keyman app didnt auto start, and its logo near the clock is showing 2d, unlike 3d as shown in your website as before it was showing. I installed that another hindi again and Heidelberg again, and Hindi is working in Heidelberg, but Latin is not (It was working before I uninstalled another Hindi). I wanna uninstall that another Hindi one, and keep just Heidelberg. I disabled the others and kept only one enabled out of DE, US, US international. What to do? Heidelberg Input sol. has options to add/remove language; share keyboard. But those options pops up after a few seconds and frozen up (but help chart opens up fine), so it’s definitely having a problem with the Keyman, perhaps due to Heidelberg or for something else. My PC is quite strong.

Hello @Michael_X ,
It seems that the add\remove language pop-up is not working for anything but the first Devanagari Unicode [DE] Keyboard. I have raised a issue Issue #8185 So we can work on a solution.

The second issue with Heidelberg installation could be because Windows only handles 4 what Microsoft term transient languages. You may have reached that limit. However, I can not be sure. It is working on my installation. Having the configuration for add/remove language is not helping so I will address this first.

Today the keyman was working. However, I had installed the first Hindi keyboard again yesterday hoping that it will help. So it was working, but when I uninstalled that first Hindi again, it stopped working Hindi and Latin in Heidelberg again. But after sometime, when changing language in the hotkey (Alt Shift) when the Heidelberg’s Devnagari showed I pressed Enter. And it started working again. I guess the problem lied in the Heidelberg module. Problem solved.

Also, the keyman logo in taskbar view sometimes shows the 3d logo on the default English keyboard.

My total list of keyboard shows one Hindi keyboard in the bottom, which I suppose is for the devnagari script from Heidelberg coz its just for show and I never installed it.

It seems it may happen if we uninstall a module, and then pressing enter during the popup hotkey toggle selection worked.

heidelberginputsolution is one of our legacy keyboards. Because of licensing restrictions we cannot update it. It’s supposed to work with Hindi, Sanskrit and Pali, but only in the Devanagari script.

I don’t know if the issue is related to this particular keyboard only, but you might experiment with other keyboards to see if another keyboards works better for you.

Thanks, it is working fine now. The alt shift toggle shortcut is not working everytime, but when I open the configuration box of keyman then the toggle key works.

The toggle has been working fine now, but the one Hindi-US at the bottle is just for show, it is caused by heidelberg. Its just an English keyboard, not hindi and doesn’t go away even if we disable all heidelberg ones. Im sure its a residue of heidelberg.

I am glad you have the main keyboard that you need.

I think this is because the keyboard language may have the wrong language associated with it. This can happen on installation when you reach the maximum transient Languages. Issue #8185 Has been resolved, however, we have not released a minor update for version 16 with this fix yet.

I will post a message back here in this topic thread once when we do.

1 Like

kindly suggest how to remove that last keyboard in the bottom in the screenshot in the list Hindi-US. I may have installed it but it doesnt show in the keyman. Uninstalling Heidelberg didn’t remove it. There maybe some file in the programs files folder which I can delete it directly or something. The only keyboard shows in keyman is the Ancient Greek, but not Hindi. (The other Greek keyboard is from Windows settings).

I think you can click on the language in the taskbar (in my case ENG) and the click on “more keyboard settings”

Then you can click on the 3 dots next to the keyboard you don’t want and click on “Remove”.

I’m on Win11 now, but it should be similar for you.

No, I have tried that. In my windows 10 language, I have only the default English and Greek polytonic. No Hindi. I will try to reinstall Keyman.

I wish I had a definitive answer for you, but I’ve struggled with this. Here’s something to try:

From Windows Settings, start typing “Edit language and keyboard options” and select that option when it appears. Then look under “Preferred languages”. Does the Hindi show up there? If so, try deleting it and rebooting the computer.

No, Lorna also suggested the same and it’s not there. I unintalled Keyman, but Hindi is still there, which means it was the first Hindi I installed before installing Heidelberg in keyman; but Hindi doesnt show up in keyman to be uninstalled. But in a deep setting i can see hindi but theres no option to remove it. From language bar option, it shows on the left box. On the right Advance keyboard settings you can still see Ancient Greek but it is unavailable, bec keyman has been uninstalled; why is it still showing in the list. But the main keyboards are only 3 right now, Default Eng, one greek and Hindi US, from the keyboard option.

फ़िक्स्ड FIXED. I am feeling stupid, since this problem I faced long ago and found the youtube solution that time as well. We should search on youtube for all such tech and windows problems first. It is easily fixed from powershell. Sometimes languages dont show up in the settings but only powershell will either show it, or we can resent languages from there


New-WinUserLanguageList en-US    
Set-WinUserLanguageList en-US

I installed other Hindi keyboards afterwards and found out that those top Hindi and Sanskrit vedic; I tried two of them, they are the ones which additionally install a Hindi-US. This additional one dont show up in the layout setting of that Hindi keyboard in keyman, that we can remove it. So eventually I installed Heidelberg again, it gives a couple of Latin transliteration, and the Hindi one. Each of them can be easily disabled, no need to go into layout setting. You should inform those Hindi keyboards about this annoying pbm, coz nobody wants an additional keyboard in the toggle option; we want only the relevant ones for time saving.

For some reason this time that additional Hindi-US did not remain like last time when I uninstalled those Hindi keyboards, it went along with them.


Thanks for reporting back on the solution so others will benefit!