Keyman 14 Beta Feedback

When I upgraded to 14beta Keyman added to my Windows 10 language bar pretty much every language available! Over 100 are now listed as being installed. But in the Windows Settings, they don’t appear at all as being installed languages! This is really confusing, please help,

Ouch! Welcome to the community @Daniel_King, and I’m sorry it has to be in such a way :upside_down_face:.

This is a known issue in the beta, reported here: bug(windows): update Keyman and all languages related to EuroLatin keyboard got added without user's knowledge · Issue #4445 · keymanapp/keyman · GitHub. A workaround to resolve the issue (until we find and fix the root cause) is to go into Keyman Configuration and uninstall and reinstall the keyboard that is listed for every language.

I am glad it’s a known issue. However, I can’t uninstall these keyboards since they do not actually appear at all when I open Keyman Configuration under the list of installed keyboards. They are visible on the quick-open menu and the Win10 language bar, but not in Configuration Window.
I don’t have Eurolatin installed at the moment, though I did at an earlier point, and probably I still did when the bad update was made.
thanks for your help

I’m sorry to hear that :frowning:

If you are willing to remove all the languages and start again, then the following Powershell command can do that:

Set-WinUserLanguageList "en-us" -f

You would replace en-us with the language code for your preferred default language: en-us is English (United States); on my computer I used en-au, English (Australia).

After this, you may still need to restart Windows in order for Windows to get its language list in order, but this should remove all of those extra languages.

WARNING: this will mean reinstalling all your Keyman keyboards – as they will lose their language associations. And of course, you’d need to reinstall any other keyboard layouts you have installed as well.

Thanks very much, that seems to have worked. I have now un-installed EUROLATIN, which seems to be the cause of issues. Is that what you’d recommend for now? It was a useful keyboard, though.

I always seem to be having difficulties lining up the Windows Languages system with the Keyman system - e.g. I have Syriac installed as a Windows language but it does not appear in keyman. If I then download the Syriac phonetic keyboard in keyman, I end up with two Syriac phonetic options in the language bar (one from Windows, one from Keyman) and they behave slightly differently in practice. I suppose this is not a major difficulty really - one can easily live with it, it just makes one doubt that the two systems are compatible.

You can reinstall the keyboard now – it will be fine to use. We will have a fix for this in an upcoming beta, and then the problem should not recur.

We’ve done a lot of work in 14.0 to try and improve the compatibility between Keyman and Windows for keyboard-language associations and I am hoping that this will be better now. You can remove the Windows Syriac phonetic keyboard and the Keyman one will continue to work (you have to look at the Language Options for Syriac to remove just one keyboard)

ok, thanks. I have done that . Seems good so far. I have noticed that from time to time the Alt+Shift method for bringing up a quick-change window stops working, and then restarting Keyman makes it ok again. That’s just a small bit of feedback, not a major thing at all. It’s a really good piece of software, keep up the good work

1 Like

Good to hear that things are working better. If you see a pattern emerging for Alt+Shift, please do follow up with us so we can look for a resolution. You could also send us a diagnostic report when Alt+Shift isn’t working so we can see if there is another piece of software that is conflicting or something else that is easily remedied.

I just downloaded and installed keymandeveloper-14.0.266. This seemed to work fine until after system restart the Keyman Developer 14.0 Setup dialog showed up again and when clicking on Install Keyman Developer nothing happened any more. After that I clicked on a kmn file I was in the process of developing but instead of Keyman Developer a dialog box showed up saying:
Application Error
Exception EAccessViolation in module sentry.dll at 0000CB15.
Access violation at address 52A5CB15 in module ‘sentry.dll’. Read of address 00000010.
Then I tried to reinstall Keyman Developer 14, but again, after the initial Keyman Developer Setup dialog comes up and I click on Install Keyman Developer nothing happens any more.
I hope the problem can be found and solved.
I will now try to uninstall this and reinstall Keyman Developer 13.

@Roland_Fumey, welcome to the community!

The Setup dialog appearing after restart is a known issue; you can ignore that safely. We want to address it but just haven’t had time as yet.

In terms of the Exception, that’s a pretty unexpected error. Can you give me a bit more detail about your environment:

  • What version of Windows are you running?
  • Is it possible to start Keyman Developer 14 from the Start Menu?
  • Did you install Keyman 14 for Windows as well as Keyman Developer 14? (If not, please try that)
  • Once you have version 14 installed, can you try running diagnostics following the instructions at and send the diagnostic report to us?

Hi Mark
Thanks for your reply. I’m running Windows 10 Pro 64bit (Version 20H2, OS Build 19042.867).
I now reinstalled Keyman Developer 14 (14.0.266). (I had gone back to version 13 so that I could continue working on my keyboard.) This time I wasn’t told that I needed to restart the system.
I started Keyman Developer 14 again by clicking on the kmn file I’m working on and the same exception occurred again. I have not yet installed Keyman 14. Keyman 13 is installed but not running at that moment. (InKey 2 is running at that moment, in case that makes a difference.)
Then I started Keyman Developer 14 from the Start Menu as you suggested. This time it came up as it should.
Then I quit Keyman Developer 14 and started it again by clicking on the kmn I’m working on, and now it works fine as expected every time!
I have installed the tsysinfo.exe and sent you the report. I hope this will be helpful.
Thanks for looking into this,

Hi @Roland_Fumey,

Thank you for the extra detail. That should be sufficient information to reproduce the issue; I have documented it for future investigation at bug(developer): if first launch is by double-clicking .kmn, error with sentry · Issue #4802 · keymanapp/keyman · GitHub.

Keeping my fingers crossed. Expecting Initial Caps and Autocaps after fullstop in Keyman 15.

Sadly, I don’t think this will land for 15.0. We have one of our lead devs away for 6 months and we just don’t have the capacity to implement this now – I am very disappointed :sob:. Everything always takes longer than we want it to!

Disappointing, but I understand :sob:

Please, where can we give feedback on the alpha? Seems the globe key in the 15 alpha is behaving completely different from her predecessors.

Feel free to start a new topic on this forum for 15.0 alpha feedback :slight_smile:

If it’s Keyman for Android, we recently added separate short-press and long-press globe actions

With 1 Keyman keyboard installed

Both short-press and long-press globe brings up the keyboard picker menu

With 2+ Keyman keyboards installed

Short-press on the globe switches between keyboards
Long-press on the globe brings up the keyboard picker menu

Thanks. I’ve started it here: Feedback on Keyman 15.0 Alpha

@darcy I’ve replied to your comment under this new topic.

1 Like