Keyman 11 Beta Feedback


#4

On the Products dropdown, look for pre-release versions.

https://keyman.com/downloads/pre-release/


#5

We’ve just announced the beta. Visit https://keyman.com/11/ for more details.


#6

I don’t think the installation steps for the Linux version in the announcement are complete. You also need to type “sudo apt-get install keyman” I think.

After this third step, I do have Keyman on my computer, and I can download and use a keyboard on it.

My linux version is Wasta Linux 18.04, which is based on Ubuntu.


#7

Thanks @Steve_White, we’re working on fixing that now :slight_smile:


#8

Language: English-US
Keyboard: gff_amharic v1.7
Device: MacBook Pro
Keyman: 11.0.200
OS: macOS Mojave v10.14.2

I found two issues with this configuration:

  1. The Keyman “About” menu item launches a splash screen, and thats it. Just the splash screen image appears and no text. The image stays in the foreground on top of all other applications and there is no way to close it.

  2. The input method does not support letter composition, the 2nd keystroke does not modify the first. So in Amharic typing “k” => “ክ” , typing a following “a” leads to “ክa” and not “ካ” as expected.


#9

I see the page is updated. It now says sudo apt-get install keyman onboard
What does the word “onboard” do in that command line? Is my test machine missing something because I didn’t enter that word in the command?


#10

Per @DanielGlassey , onboard is needed to get the OSK in Keyman for Linux.


#11

I also have a MacBook Pro with macOS Mojave, and I don’t see either of these problems with Keyman 11.0.200. The “about” item shows text with the image and typing ka in the Amharic keyboard gives “ካ”

Do you have problems with other keyboards beside the Amharic one?

Maybe one of the developers can chime in with some troubleshooting tips. Would removing Keyman and reinstalling it again help?


#12

Our macOS developer has reproduced the first issue you describe. He’s looking into it now.

For the second issue, which app(s) is this occurring in? Can you test also in TextEdit?


#13

I did a complete uninstall and reinstall of keyman on my macbook. previously i had simply copied the new keyman on top of the old. the behavior remains the same.

The keyboard works fine with TextEdit, Safari and Sublime. But has the composition issue with Chrome 71.0.3578.98 and MS Word 16.16.5 .


#14

So far, I have exclusively distributed kmx (or kmn for kmfl) files, and have never generated .kmp packages. But keyman for linux only accepts .kmp?


#15

Justin, I expect this is by design. I asked this question last Feb about Keyman for MacOS accepting kmx files, this is what Mark D wrote:


#16

@Justin_Luth - yes, the .kmp package is a lot easier to distribute.
Here’s a guide on using Keyman Developer to create a keyboard package:

https://help.keyman.com/developer/10.0/guides/distribute/tutorial/


#17

Another experience with the 11.0.200 osx build is that when I select from the MS Word font menu, or font size menu, it triggers the keyman onscreen keyboard to pop up.


#18

The instructions for installing “Keyman for Linux 11.0 beta” say: “On Ubuntu (gnome-shell) you need to install the Input Source in Region & Language Settings.” This is not obvious to me. Are there more detailed instructions somewhere? For example, if I want to install the EuroLatin keyboard and use it to type French, what should I do (on a standard Ubuntu 18.04 install)?


#19

I’ve created issue #1523 for this. Can you update it with your macOS version and applicable details?


#20

Hi @drowe, we are working on the documentation for Linux installation – at present the beta is available on the assumption that you’d already be familiar with your Linux distribution’s language configuration. We do aim to have documentation for popular distros available by release date.

FWIW, km-config from the console is a good starting point for downloading and installing keyboard packages.


#21

Note that km-config only installs the keyboard into IBus. The step to “install the Input Source in Region & Language Settings.” is needed for it to be used in gnome-shell.

https://help.gnome.org/users/gnome-help/stable/keyboard-layouts.html.en is the Gnome instructions for adding an input source.

For your French example on a system installed as English which doesn’t have French language installed in Manage installed languages on Region & Language settings. First you install the eurolatin keyboard in “Keyman Keyboards”. Then go to the Region & Language settings. The input source will be in Otherand it is called French (EuroLatin (SIL))


#22

Thanks, Daniel, for those pointers. Here’s what I ended up doing:

  • opened “Settings”, “Region & Language”

  • clicked on the “+” below “Input Sources”

  • clicked on the three dots to expand the list (since there are a number of flavo(u)rs of English installed)
    image

  • scrolled down to “Other” and clicked on it
    image

The first time I got to this point, Settings froze up and I had to terminate it and start over. The second time it worked, bringing up a long list of languages. I typed in “french” and scrolled to the “French (EuroLatin (SIL))” entry.
image

I clicked on that entry, then the “Add” button in the top right corner of the dialog. The new item was added to “Input Sources”:
image

and a dropdown selection list was added:
image

Thanks,
David


#23

That looks like a great capture for the docs when they get online… :slight_smile: