Keyman 10, capital k, capital m

I’m using Windows 10. After installing keyman 10, I’ve been unable to use capital k and capital m in any program. Whenever I press shift to try to type a capital k or m, the keyman window opens and I can’t get my capital k or m. I see there are some shortcuts that involve shift+alt+k or m, but I’m not pressing alt and it is as if I am.
This is very annoying!
Any suggestions?

When you installed Keyman (Desktop?), what keyboards did you install?

The default key sequence for opening the onscreen keyboard is: Shift+Alt+K and for opening the Keyman menu is: Shift+Alt+M

Clearly there is an issue with the Alt key being stuck (either physically or virtually). You can fix the immediate problem by turning off the hotkeys:

Open Keyman configuration, press Hotkeys, and set it to for both of those options.

Then we need to troubleshoot if the alt key is actually stuck. sometimes just bang on it a few times (both left and right) and it gets unstuck.

I don’t think the Alt key is stuck, or I believe it would be affecting other programs, but that would definitely be the simpler answer (and btw my computer is indeed plugged into a power source, lol)!
Thanks for the Hotkeys tip. I changed that and now I can use capital K, M, and O again!

Lorna, I’m using IPA Unicode (which shows up as Icelandic) and Portuguese.

Glad that solved it. To help the developers troubleshoot the issue, what is the physical keyboard on your computer? US, UK, German, etc. Maybe the program is interacting with the underlying keyboard which makes it act like the Alt key is pressed.

It’s a US English Lenovo.

I am one of the Keyman developers.

It’s good that turning off the hotkeys worked around the problem. If time permits, are you able to assist us with trying to find the root cause of the problem?

  1. Does this problem occur whenever Keyman is running? That is, if you were to exit Keyman and restart it, would the problem return?
  2. Also if you restart Windows, does the problem recur?
  3. With Keyman running, if you press and release each Alt key, then can you use the problematic keys as normal?
  4. Would you consider sending us a diagnostic report following the steps at

For future readers, please see related workaround at Bug with left-alt - #4 by Marc