Keyboards automatically change without my input

I’ve run across this issue twice now. I can’t remember how I did it the first time, but I’ve been able to reproduce this issue the second time.

I have the Greek Classical keyboard installed, but whenever I try to type Umineko no naku koro ni into Microsoft Word 2016, without any of my inputs, the keyboard will change to the Greek Classical, and Umineko no naku koro ni changes to Θμινεκο νο νακθ κορο νι. I’m pretty sure this is because I’m typing a foreign name using a Latin script, and none of my other keyboards match, but I don’t understand why it is automatically changing. It isn’t Word since I’ve typed that phrase numerous times before I installed Keyman.

1 Like

Welcome to the community, Sanha.

Could you please explain this issue a bit more?

  1. What keyboard is active when you type “Umineko no naku koro ni”?
  2. How many keyboard have you had installed?
  3. Did you set any hot keys to any keyboard by any chance?

Also, please send us a diagnostic report so our developer can take a closer look at it.

Here is how to send a diagnostic report to us: https://help.keyman.com/products/desktop/current-version/docs/basic_support_tab

I have one other keyboard installed, which is the Galaxie Hebrew keyboard. Other keyboards are Microsoft keyboards for English, Korean, and Japanese.
The keyboard that is active is my English default keyboard. Despite typing in English, it sometimes changes to Greek.
I also had one occurrence where my Greek letters changed to English letters. I have had no hot keys set.

That is very weird. Please send us the diagnostic report so that our developer can take a look at it.

Can you check the following option in Word:

  1. File/Options/Advanced/Automatically switch keyboard to match language of surrounding text

Also, can you let us know what you typed immediately before the text switched to Greek? That may be relevant.