Keyboard randomly changes while typing

Hi, I’ve seen there’s a topic on something similar, but I’m not convinced it’s the same problem.

Since last upgrade (16) previously working cyrillic keyboard began randomly reverting to US english.
I use russian mnemonic which came with russian language package for Windows. I can write with it, using Keyman shortcuts to switch between languages for several pages, until it randomly breaks, and then it remains broken, until it randomly fixes itself. Basicly, without any input from me, keyboard just forgets it was set to russian mnemonic, and turns the whole line to latin, as if it was the ЙЦУКЕН setting all along. This problem does not exist with any other language, including other languages with non latin scripts. Additionally, it is not possible to revert it using Ctr+Z in word.
I am at a loss as to what causes this, because I’m using standard Times New Roman as font and basic Windows settings, and I’m quite sure, it’s a bug either within Keyman or Word.

Please help

Welcome to the community @Trurl190!

Тhank you for reaching out. I understand your frustration that the Russian - Mnemonic Basic keyboard suddenly switching to Latin while typing. Please provide us more information about your system so we can reproduce the issue such as:

  • Windows Operating System
  • Microsoft Word version
  • Keyman version

Also, can I know if this problem happen anywhere else in your computer?

I had tried using this keyboard on Microsoft Office 2019 using Time New Roman font in Windows 11 Home with a Keyman version 16.0.144. It’s working perfectly fine including in Google Doc and Chrome.

Have a nice day!

This topic was automatically closed after 14 days. New replies are no longer allowed.