Keyboard cannot be uninstalled

On my Windows 10 computer, I created a new keyboard with Keyman Developer 11.0.1356. The keyboard file name contained a vowel with diacritics (ä). When I compiled the keyboard, Developer gave me a warning that I should not use these characters. But since it created the keybard I loaded it to Keyman Desktop and tried it out.
After that, I changed the file name, made some changes to the keyboard and loaded it again, and it worked.
The only issue is that the first trial keyboard, (the one with ä in the filename) is still installed in Keyman Desktop. I cannot remove it.
I tried uninstalling Keyman (using Revo Uninstaller to catch references in the registry), then rebooting and reinstalling Keyman Desktop and Developer. The link to the keyboard is still there.
I tried re-creating the keyboard file, and keyman actually links to the new version (I can see what has changed from that first trial version), but I still can’t remove it from Keyman Desktop.
Any ideas on how to remedy this situation?

It is finally gone!
This is what I did. I uninstalled Keyman Desktop and Developer for good measure, using Revo again. Then I did leave it off the computer for a couple of days, during which I ran a registry cleaner repeatedly, deleted all the entries for Unknown Keyboards in the Windows language settings, and rebooted the computer more often than I usually do.
When I reinstalled Keyman Desktop it finally came up with “no keyboard installed”.
Not sure which of what I did actually worked, but I am glad it is finally gone.

You can usually uninstall a keyboard by going to Keyman / Configuration.

Then click on the “X” that is at the far top right of the listed keyboard.

Did you try that and it didn’t uninstall?

Yes, that is what I tried and it would not respond to clicking the x. I was able to uninstall all the other keyboards that way, but not this one.
After it would not respond that, I tried uninstalling Keyman, as described in my original post.

Thanks for this report; I’m glad you were able to resolve the problem, and sorry it was more difficult than it should have been. I have created an issue report based on your experience – I am suspecting an encoding issue in the user interface was preventing the keyboard from being identified correctly to be uninstalled – and will try and reproduce in due course.

It’s great you were able to resolve this! I’m sorry we weren’t more helpful.

Ooh! ooh! I have a very similar problem with phantom keyboards that Windows thinks are there but aren’t.
I’ve tried getting rid of them in Registry by deleting these lines:


But as soon as I reboot, they come back.
May I ask which registry cleaner you used?
I’ve been hesitant because so many sites have said that registry cleaners can do more harm than good. What advice can you give me.
Thanks!!

We do not advise using registry cleaners; most of them cause more trouble than they solve.

We are doing some research on why Windows leaves spurious keyboard entries behind in some circumstances. Hoping to have some solutions to this at some point before too long.

Here’s one thing that does help:

  1. Remove all keyboards in Language Preferences, remembering to go in to each language that you leave installed and remove excess keyboards from each language.
  2. Restart.
  3. Do this again.
  4. Restart.

Typically, we find this removes the spurious languages.

thanks, Marc. Removing the keyboards in Settings doesn’t help (even multiple times). The phantom keyboards don’t show up in Settings, but they are there when I click in the taskbar on
image
That’s why it seems to me that it’s a registry problem. When I try to remove the languages and/or keyboards in the registry they always come back upon reboot.
Happy Thanksgiving

Another approach I have used successfully is a clean sweep using PowerShell commands. After this you’d need to reinstall your keyboard layouts e.g. with Keyman etc.

Start a PowerShell and type:

$a = New-WinUserLanguageList('en-us')
Set-WinUserLanguageList $a -force

Restart Windows. There should be only one language installed after this. If you prefer a different initial keyboard, use that instead of en-us.

Use with care!