Issue with Myanmar3 (SIL) and Microsoft Teams

Issue raised on for further investigation bug(windows): Myanmar3 (SIL) and Microsoft Teams · Issue #8812 · keymanapp/keyman (

1 Like

Please let me know if you have any update for this.

Will do. no resolution yet. The log shows the Keyman Engine setting out the expected commands.

Ok I would like you to try copying text written in another app into the Teams chat window. Then press backspace and observe how the text deletes. Make sure Keyman is not running when you test the backspace.
Try the text below sequence acG
1 backspace = တွ
2 backspace = တ
3 backspace =

You can tray other sequences and compare it verses doing the same thing in another App such as Notepad.

when I tried to type on Notepad everything is fine and I can copy to Teams chat but when I test the backspace it removed တွေ with only 1 backspace.

Thank you for that test. It appears that this a cluster issue where the application, in this case Microsoft Teams deletes an entire cluster on backspace rather than just the codepoint prior to the insertion point. I was writing a bug report to send to Microsoft and in doing so was going through the versions of Microsoft Teams being used and I noticed your version in the first post was my version is If your version is still can I ask you to update it and try again. The reason I ask is we had the same cluster deletion problem with another application and they had actually fixed it in their latest version. If it still doesn’t work let me know as I have the bug report ready to send to Microsoft.
Thank you,

@Phyo_Wai_Kyaw Not sure if you saw my last post can I ask you to update your Teams to or later and test it again. This just to make sure Microsoft have not already addressed the issue.

hi @ross sorry for late reply I have tested with Microsoft Teams Version (64-bit). It was last updated on 04-May-23 but still same issue here

1 Like

@Phyo_Wai_Kyaw I have raised a query with the Microsoft feedback portal and I haven’t heard back yet. However, I have heard from a Microsoft contact that suggests testing other applications that use the Electron framework. This may help to narrow down were the problem is occurring.
Probably the most common one that you could test with to see if the problem exists is Visual Studio Code, if you don’t have this it is free to download from here Visual Studio Code. If you are willing you could try this and report back how you go.


@ross as I checked here and found that we did not faced those kind of issue on another apps like Viber for example.

Ok thank you for checking.

hi @ross let me know if you have any update on this? we still have issue here.

I just checked where I posted the problem to the Microsoft Teams Forum and there has still been no reply, unfortunately. I will see if i can find another avenue to raise the issue with Microsoft.

This topic was automatically closed after 14 days. New replies are no longer allowed.