Issue with Myanmar3 (SIL) and Microsoft Teams

We have issue with Myanmar2 (SIL) v1.7.3 and Microsoft Teams Version (64-bit) that some word can’t show or type correctly like ရွှေ လုံး သုံး တွေ etc… there maybe more. Please help to check and advise me.

Welcome Phyo Wai Kyaw! Can you tell us if the problem is with typing the characters or with display of the characters? If you type in another application and paste the text in Microsoft Teams, does it display correctly?

When you say it won’t type correctly, what is not happening? Does another keyboard work properly in Microsoft Teams?

We need to understand if it is an input problem (keyboard) or a font problem (display).

Hi Lorna, thank you for your reply it is a problem with typing some characters. I can type in another application with no issue and paste the text from another application to Microsoft Team also display correctly. I have not tried with another keyboard yet and as per my finding I faced issue after I upgraded keyman version 16.0.139. before that version everything worked fine.

I suspect this is an interaction with the Keyman program and Microsoft Teams @Marc?

Hi @Phyo_Wai_Kyaw,

I’ve tried to reproduce the problem here. I have tested with Teams (64-bit) and (64-bit).

There may be multiple ways to type the words you have shown us, and that may be relevant.

For ရွှေ, I typed a&GS (Unicode U+101B U+103D U+103E U+1031).
For လုံး, I typed vkH; (Unicode U+101C U+102F U+1036 U+1038).

I was not able to find any problems with either of those words in my test. Can you:

  • tell us which area you are typing these words in Teams
  • share the exact key sequence you use type, if it differs from what I have above
  • copy the text from Teams to the clipboard and paste it into your reply here
  • share a screenshot of the result in Teams
  • share a diagnostic report with us, following the steps at KMKB0040

Here’s a screenshot from my test:


1 Like

hi @Marc thank for your reply and my teams version is and
For ရွှေ, i typed a & G S but display below
For လုံး is ok as per your word
For တွေ I typed a w G but display below
For ငွေ I typed a င G but displayed below
ှေ ွေ ွေ
I suppose it was issue on a combination between a and G with other words (a w G, a c G, a u G, a e G etc…) I tried all combinations and it faced the same display.

Thank you for the additional information. I have reviewed the diagnostic report, and attempted again to reproduce the problem here, but so far am unable to reproduce it.

It may be possible to change a setting in Keyman to attempt to workaround the issue. These settings are here for diagnostic purposes, so not recommended for general use. However, it is worth trying them:

Option A. text_services_framework

  1. Open Keyman Configuration, click Options tab, then click Keyman System Settings button:

  2. Click Yes when prompted to allow Keyman to make changes:


  3. Locate engine.compatibility.text_services_framework in the dialog, which should currently show 1 as its value:

  4. Click on the value and change it to 0, and press Enter, then press the Apply button.

  5. Close the dialog and Keyman Configuration, and restart your computer (alternatively, restart Keyman and Teams, but this can be trickier)

Option B. serialize_input

If Option A above doesn’t work, reset the setting to 0, and then try and set the engine.compatibility.serialize_input setting to 0 instead, following the same basic steps as above.

Let me know how you go!

Dear @Marc thank for your solution and kindly see below the result of my testing. a&GS aiG vHk; ayjm. please check and advise me.

Option A testing result

Options B Resutl

OK, so it looks like neither of those options helped. Just checking – did you restart Windows after changing the setting, before running the test?

The only thing I can think of now is to setup a remote support session, where we may be able to capture some more detail about what is going wrong. Would you be willing to do this?

Hi Marc, I just restarted Microsoft Teams and Keyman only and let me know when can we have remote session. I am located GMT +6:30 here

Continuing the remote support conversation in private message.

hi @Marc waiting in remote support here.

hi @Marc are you planning to join the session or postpone to another day?

Hi, I did not receive any confirmation and ended up with a different meeting at the same time, sorry. Can we reschedule for tomorrow?

If you are ok now. we can join the session now

Sorry, I am not available until tomorrow – are you available at the same time tomorrow?

ok then see you tomorrow same time

Great – I am sorry for the mixup, see you tomorrow!

1 Like