Is Package for Distribution supposed to create an "untitled.kps"?

#1

I just created a package using Keyman 11. It added a keyboard (langName.kmn), and packaging (langName.kps) file to the project with all of the appropriate settings.

But, it creates an untitled.kps file when I do this:

  1. Open the langName.kmn file.
  2. Go to the Build section
  3. Click Package for Distribution

The untitled.kps file no longer has a BCP 47 tag, as the langName.kps file does.

I can access the langName.kps file by doing this:

  1. Go to the Project
  2. Click on Packaging
  3. Click on langName.kps

The untitled.kps has me confused. Is that supposed to happen, or is “Package for Distribution” supposed to take me to langName.kps? I have accidentally saved untitled.kps as langName.kps (overwriting the correct/existing langName.kps), so wanted to mention it.

Keyman Developer 11.0.1352.0.

0 Likes

#2

Yes, the .kps is the keyboard package. For instructions creating a .kps, go to https://help.keyman.com/developer/11.0/guides/distribute/tutorial/

0 Likes

#3

Thank you for your reply Makara. I understand that the .kps file is for the keyboard package.

My confusion comes when there is ALREADY a langName.kps file associated with the project, why does Keyman create a NEW untitled.kps file when I click “Package for Distribution”? It seems that Keyman should be opening the existing langName.kps file (which has the appropriate settings) when I click on “Package for Distribution” instead of creating a new one (which does not have the appropriate settings).

Thanks,

James

0 Likes

#4

I think you want to click on the .kpj tab (just below the menu bar), then on the “Packaging” tab at the bottom of the screen to take you to the existing .kps (Keyman Package Source) file.

But you are right that there is room for improvement in the Developer UI.

1 Like

#5

The “Package for Distribution” menu item is a holdover from earlier versions of Keyman Developer where the package was not created automatically as part of the project. We’ll take your feedback on board :slight_smile:

0 Likes