iOS keyboard package cannot be installed in the Keyman app (keyboard testable properly in phone browser)

Greetings! I’m new to Keyman Developer though I’ve been using some Keyman keyboards and have been creating my own keyboards with Ukelele for many years.

Recently I started a test project trying to make an iOS keyboard and the process was fairly smooth. I simply repeated my layout for the macOS previously made in Ukelele and rearranged a bit in the touch design for iPhone and everything looked great: I could test the layout on my phone browser; I could type properly and the Arabic based script connects properly; (additional) diacritics were fine; long-press keys worked fine. But, I cannot get it properly installed in the Keyman app.

Before I was able to test it in my phone browser, I actually tried the “install from file” option by transferring the .kmp file to my phone and the issue was already there. I initially suspected there might be something wrong with my package so I purchased a USB wifi adapter in order to put my virtual Windows on the same network with my phone to test the keyboard. But the issue remained the same.

According to the instructions, no matter how the package is loaded onto the phone (browser download or “install from file”), once I click in the file, the normal installation process should start. But I never saw it. I am sure I set the language code properly, but I cannot find if from the language list. I tried uninstalling and reinstalling Keyman from my phone and the issue persists.

When I go to “installed languages” on my phone, a green banner pops up from below saying “update available.” I can click on it and in a second or two, it turns into “updates successfully downloaded” and disappears. I assumed it could be something about my test layout being loaded, but I could not find it in the language list, and this green banner shows up every time I go to “installed language” after I clicked on the .kmp file (previously via file transfer, currently via the installation link from the phone browser test page). This was the same issue before I managed to test the keyboard in my phone browser.

Does anybody know what is going on?

Many thanks!

Welcome to our community.

Could you give us some more details?

  1. What is your iOS version?
  2. What is the Keyman version you are using to test this keyboard?
  3. Can you DM us the keyboard so we can test it on our side?

Thank you for your response.

My iOS version is 14.2. The Keyman app I installed is 13.0.113.

By DM do you mean I could message you and attach the .kmp file?

Btw, here is the image after I clicked on the “update available” banner. I was not allowed to attach more than one image when I posted the question.

Thank you for the info. :slight_smile:

You can click on my profile picture, then Message and then you should be able to start a direct message.

You can copy and paste as many images as you need right in the text box.

Thanks! I have just messaged you with the .kmp file I made.

And, thank you, I did know how to attach images and I tried to attach more images when I created the post, but I was somehow not allowed as a new member lol I attached the second image to show what I described originally in my post. Even now, when I go to settings — installed languages, the green banner pops up as in my first image, and I can click on it, then it disappears to show the second image, and then the green banner disappears entirely. However, nothing appears to be added in the language list. If I exit and go to ‘installed languages’ again, the whole thing repeats.

Ah, newbie issue. :smiley:

Probably you can upload the images to Google Drive and share the link with me.

I will get the iOS developer in the loop and we’ll see what is going on. Thank you for the report. :+1:

Thank you. I’ll try other ways of image sharing next time.
And thanks for bringing in the tech team. Looking forward to a conclusion for this mystery.

It looks like I’ll need additional information regarding your issue - everything is working fine on my end.

When testing in the iOS Simulator:

Testing on my personal device:

That said, it’s probably worth noting that I’m doing these tests on the current Keyman 14.0 alpha. There’s a small chance that there’s something specific to the currently-released Keyman 13.0 that’s going wrong… assuming that you’re on that version. Even then, I still get a valid install within Keyman 13.0, at least on the Simulator.

One more question - when Keyman launches after trying to ‘open’ the KMP (from Files, from an email attachment, etc), does anything show up that references your package? I’d expect something like this to show up:

Thank you so much for your response!

It is indeed weird… I could test it pretty well in the browser, no luck at all for the installation.

When I navigate to the KMP file from ‘install from file’ in the Keyman app and tap on the KMP file, nothing happens at all. It just remains on the file viewer page. Nothing pops up, as if I did not tap on anything. The very last image you showed never appeared on my phone. I read from instructions that I should expect the normal installation process but it did not initiate.

Hi, Does anyone have a video on how to use Keyman Developer because I need a example.

Hi @YawReh, welcome to the community :slight_smile:

Have a look at our Keyman Developer Training Videos at – there are a whole set of training videos that take you from the very beginning through to a complete keyboard ready to share with your language community.

Sorry to bother you again. Any idea about what is going wrong with my KMP file in the current version? Should we be expecting a new version update soon?

Nothing pops up?

I’ve seen an issue like this occur when a device is using iOS 12, but haven’t seen this occur with iOS version 13 or 14. My personal device is iOS 14.2, but as seen in a previous screenshot, it had no issues with your package.

How did you place the .kmp file on your phone? Can you verify that it has the same file size as the original copy on your computer? At this point, I’m wondering if there’s a chance that the file became corrupted.

Then again… where it was working before on my phone, now things aren’t. I’m having an issue opening other .kmp’s now. I haven’t seen this exact behavior before; it’s a bit different than the iOS 12 behavior I was alluding to.

We do plan to start the next beta for Keyman soon, and this is happening even on our prototypes for the next version. I’ll definitely be looking into it, but can’t make a guarantee on the timeline just yet.

Exactly, nothing. Again, as I said, I initially suspected that the file was somehow corrupted and did not post the question until I managed to test it in my phone browser.

I tried it in three ways: (1) airdrop the KMP file; (2) access the file from iCloud; (3) attempt to install from the browser test page. Nothing happens when I tap on the file. They are of the same size, suspiciously small but apparently it worked on your end. When I messaged the file here, I was uploading it from my iCloud folder so it is the same file I tapped on multiple times.

Omg… that’s very sad news to hear… I hope things could be sorted out. Such a mysterious bug…

I’ve found one error that results in behavior like that, though it’s not currently clear whether or not the error is the same as you’re experiencing. I’ve made a fix against the current iOS alpha here:

It’ll take a day or two to be available through TestFlight, which would require signing up through links found on this page: Only “alpha” will have the attempt at a fix for now, after about 24 hours from this posting.

Thanks a lot!!! I actually have TestFlight on my phone which I volunteered to test another app. I will try and see how it works.

I’ve just given it a try. Still nothing happens when I tap on the KMP file. I turned off the dark mode just in case the display might mess up in some ways.

Now, the green banner still appears when I go to ‘installed languages’ section, and I can tap on it.

But the difference in the alpha version is: after tapping on the green banner, the app shows a second or so ‘updating’

Then the app crashes.

I saw the new alpha updates and tested my KMP file again. The results are the same as above. The installation page doesn’t show up and the green banner behaves as described above, and crashes as it’s displaying ‘updating’

Thanks for the response. Seems like I’ll have to keep looking into it.