How to insert an unbreakable space

Up until now, in books produced with MS Word, MS Publisher etc, we have used the unbreakable space between words and their following article to help (beginning) readers. This is because nouns and their articles, although written as separate words, are always pronounced in one breath. We would like to continue with that habit. Is there a key-stroke for an unbreakable space in Bloom? And if not, how could it be produced ?
Thanks in advance for your help.

When typing in Bloom, you can “longpress” (hold down) the space bar. That will bring up the UI to let you insert a non-breaking space.

In case you are unfamiliar with this “longpress” feature, there are special characters which can be inserted this way for most keys. For example, holding down “a” will give you options for these characters: āăàáâãäåąạa̱ɑæαª.

1 Like

One place where non-breaking spaces are really important is in orthographies that follow the French pattern of a space between a word and following colon, question mark, etc. Those should stick with the word they follow. We ran into this using Bloom in Senegal and Mali.

1 Like

Hello Andrew, this is new information to me. However, I cannot get it to work. If I press the spacebar down continuously, I get continuous spaces :

Are you sure this is a feature in bloom 5.3.6 (windows 10) ?

Hi Bart. This works on my machine (windows 10), Bloom 5.3.6.

I wonder if some keyboard program (keyman?) or Windows settings is causing this to not work on your machine?

Hi Colin,
No idea why this is not working. Maybe because I do not have a “touch” screen ? Even quitting keyman and selecting ENG-INT as keyboard, no luck.

One internet help suggests:

But there is no such thing as : Enable press and hold for right-clicking on my laptop …

Any tips are more than welcome.

Yeah Bart we call our feature “long press”, and Microsoft and others have touch-related features named the same thing, but they aren’t related.

This is just a keyboard thing, where Bloom notices that you’re holding down a key for a long time.

@Bart_Eenkhoorn I too am finding that long press on space isn’t working. Try long pressing on “a” instead, so at least you will see how it is supposed to work.

OK, what we have here is a bug. What I am seeing is that long-press spacebar does nothing if your cursor is at the start of a text block or the end. And maybe there are other situations too. Try playing around with where the cursor is. This is what you should see:

No luck with “a”

OK, I am now getting the menu for “a” in a normal text box, but not on the first page title screen … After I activate keyman, the feature stops working.
Since the team is used to working with keyman all the time, the longpress feature really should work with keyman activated. Or could bloom possibly be equipped with some shortcuts like MS Word has for non-breaking space etc?

@Bart_Eenkhoorn What Keyman keyboard are you using? Perhaps it already has a combination for inserting a non-breaking space (or perhaps one could be added).

If you’re using the sil_mail_azerty keyboard (Clavier du Mali (Azerty) keyboard), the sequence kks produces a non-breaking space (U+00A0).

1 Like

Thanks Dave, it works! I did and try to look that up in the helpfile, but the best I could get was this … where did you find out about the kks sequence ?

Clavier du Mali (Azerty) Keyboard Help will show the online help for this keyboard. Down at the very bottom that sequence is listed.

The help packaged with the keyboard has similar information. If you have that keyboard selected, then click on the icon in the system tray, you should be able to select Help from the menu and Keyman should offer you a choice for Help with the specific keyboard that’s active.

Oops. I see you’re using the Qwerty version: which doesn’t list all those extra key combinations that the Azerty version does (though they evidently are there for both versions).

Thanks again Dave. Now the next challenge is to know if yes or no an unbreakable space was typed in bloom…