How to disable the CTRL-hotkey?

In my Keyman Configuration I have set the following hotkeys:

  • F3: English
  • F4: Greek
  • F5: Hebrew
  • F6: IPA

The F-keys work as they are supposed to, BUT it appears that the CTRL-F3/4/5/6 keys are now also reserved for the same command! How do I disable this for the CTRL-F3/4/5/6 combinations?

Welcome to the community.

Can you let us know your Keyman and Windows versions?

Keyman 13 and Windows 10

The behavior cannot be replicated on my side.

When the F3/4/5/6 are set for the keyboards, no Ctrl + F3/4/5/6 are active.

Can you try and disable the hotkey all together and the re-enable them the way you want them to be? Let me know how it goes.

Yep, it still gives the same issue.

So, I disabled all hotkeys in Keyman and the F3/4/5/6 keys were functioning as in default. Also CTRL+F4 was closing a panel. Then I assigned F4 to my Greek keyboard in Keyman, and that works, BUT my rightside CTRL+key+F4 also toggles on/off the Greek keyboard, instead of closing a panel.

Interestingly, the leftside CTRL+key+F4 does the closing of a panel and not changing the keyboard!

I was wondering if I can redefine the hotkeys in Windows somewhere. I know it is possible somehow, but I forget where to do it and I can’t find it on Google.

Hi @michel_pauw, it looks like you’ve uncovered a bug in Keyman. I don’t think we had tested scenarios with modifier keys (such as Right Ctrl) together with hotkeys like F4. We have focused our testing so far on hotkeys such as Ctrl+Alt+K.

I’ve documented the problem on our issue tracker and hope to have a resolution before we release 14.0 stable.

Unfortunately, I don’t have a good workaround at this stage, other than to use a different hotkey.

Thanks, Marc. When do you expect this new release of 14.0? Weeks, months, years?

14.0 is due out at the end of March, all going well.

Okay, that’s pretty soon. I hope this fix can be included!
I used to have a sequence of F3/4/5/6 for different languages on my old computer. Now, when I installed the latest Keyman on my new laptop it didn’t work.

I did not test the right Ctrl. Now that I do, I still cannot reproduce this behavior with Right Ctrl, but as noted in the issue tracker setting F4 as a hotkey for keyboard would enable AltGr + F4 for that keyboard. Nothing happen when pressing Right Ctrl + F4.

Beta release 14.0.258 should contain the fix for this issue, available tomorrow, downloadable from