Hotkeys using ALT don't work

I just downloaded the latest version of Keyman (14.0.275) on Windows 10. I’ve previously always set Ctrl+Alt+G and Ctrl+Alt+B to switch to a couple of different keyboards (not standard Keyman ones, created by a colleague using Keyman). Now if I set those same hotkey combinations for the same keyboards, they don’t work, but if I use Ctrl+Shift+G/Ctrl+Shift+B, they work fine (and no, there’s nothing otherwise wrong with my Alt key). Anyone encountered this problem/have any idea how to fix it…? Obviously I can just use the Shift hotkey combos but remembering not to use the Alt ones I’m used to is difficult! Thank you!

Hi @annaj, welcome to the community!

Version 14.0.275 does make a change to hotkey management to fix a problem with stuck hotkeys. In our testing, we didn’t encounter any problems, but it is possible you have run into something that isn’t quite right now.

You can turn off this new setting by changing the flag “engine.compatibility.old_cached_hotkey_modifier_state” in the advanced Keyman settings:

  1. Open Keyman Configuration

  2. Click on Options, scroll to the bottom of the list

  3. Click on Keyman System Settings, accept the Admin prompt

  4. Select the value for “engine.compatibility.old_cached_hotkey_modifier_state” and change it to 1.

  5. Click Apply, Close, then shutdown Keyman and restart it (these “advanced” settings do often require a Keyman restart)

If this resolves the problem, then I might ask if you’d be willing to share a debug log with me to replicate the problem.

Thank you so much Marc, that worked! Ctrl+Alt hotkeys working fine now :slight_smile: Happy to share a debug log, is that the ‘diagnostics’ option in the Support tab?

Hi @Annaj,

That’s both good news and bad news I think – the good news is the compatibility flag fixes the problem for you, but the bad news is that the fix we made for the stuck hotkeys issue has had side-effects that we didn’t expect :frowning:

Two options:

  • You capture a debug log and send it to me, following the steps below, or
  • We can setup a remote support session and I can capture the debug log on your machine.

Capturing a debug log

Capturing a debug log requires turning that compatibility flag back to 0 again and then taking the following steps:

  1. Exit Keyman
  2. Open Keyman Configuration, select Options tab, Debugging.
  3. Read the warning that is shown :slight_smile:
  4. Start Keyman again
  5. Select a Keyman keyboard and type a very short message into a document (just one word is enough). This verifies that Keyman is operating “normally”
  6. Then, press the hotkey that doesn’t work (confirm that it is not working)
  7. If possible, press a hotkey that does work (confirm that it is working)
  8. Exit Keyman
  9. Click Start, type %localappdata%\Keyman\Diag and press Enter
  10. You should find one or more files called system#.etl (where # is a number).
  11. Send those files to me via a private message on this forum. Tell me what you typed, and the hotkey(s) you pressed, and their outcomes, so I can locate them in the log.
  12. Make sure you turn off the Debugging option again, and reset the compatibility flag to 1, before you restart Keyman.
  13. Finally, if you can also send a diagnostic report from the Support tab, that may help me understand your computer configuration.

KMKB0076 Debug Log Reference

Hi Marc,

I just tried to run the debug as instructed but when I switched the compatibility flag back and tested the keyboard, it turned out the keyboard wasn’t working at all, so it seems like the issue might be with the keyboard’s compatibility with the new version (as I said before, it’s a custom keyboard developed by a colleague) rather than with the hotkeys. Or possibly it’s both…

Thanks,

Anna

Hi Anna,

Would you mind trying to run the debug in any case? It may still provide me with helpful information.

Thanks,

Marc