Hotkey doesn't work on SIL Hebrew 1.7


#1

Hotkeys don’t work to switch to SIL Hebrew 1.7. I can assign them, but they have no effect. (They worked in previous versions.)

Keyman Desktop 10.0.1104.0
SIL Hebrew 1.7
Windows 10 Pro, Spring 2018 update


#2

Hi Barry

We’re tracking hotkey issues in GitHub issue #927.

What’s the hotkey assignment that’s not working? (e.g. Custom: Ctrl + Alt + H)


#3

I haven’t found any key combination that works for SIL Hebrew 1.7. I’ve tried the following:
Ctrl + Alt + H
Shift + Alt + H
Shift + Ctrl + H
Shift + Ctrl + Alt + H
Shift + Ctrl + Alt + I
Shift + Ctrl + Alt + A
Each will show as being assigned, but none of them switch the keyboard.

As a test, I assigned each of those same combinations to my SIL IPA keyboard, and they all worked. (Makes me think it’s not a key combination conflict.)

FYI, I also just installed a Dell bios update, (Inspiron 3250 mini-tower), and changed from Keyman Desktop 10.0.1093.0 to 10.0.1104.0. (And, I may have changed from the previous version of SIL Hebrew to version 1.7, all at the same time. :frowning:


#4

@Barry, if this is happening only with SIL Hebrew 1.7, it sounds like more of an issue with the registration of that keyboard. Can you check a couple of other things:

  1. Can you select the SIL Hebrew keyboard through the Keyman menu or the Windows language switch menu?
  2. Does this problem occur in all applications or only specific apps?
  3. Can you send us a diagnostic report which will come in as a private message to us; reference this conversation when sending the report. That’ll help us to dig in to what’s ‘special’ about that particular keyboard.

#5

@Marc_Keyman, yes, I can select SIL Hebrew through either the Keyman menu or the Windows language switch menu.

But, its hotkey doesn’t work in any app I’ve tried, (Notepad++, Firefox, Thunderbird, Windows Explorer, Excel, Word, or Notepad). (Hotkeys to English and SIL IPA keyboards work everywhere I’ve tried them.)

I’ve generated a System Diagnostic Report, and will send it now.


#6

Barry, I’ve put this onto my list for deeper investigation next week because I’m not understanding what’s going wrong – there’s something that’s not right, for sure.


#7

@Marc_Keyman, you may want to use your time next week for something else; I’ve found the problem. (I’ve found the enemy, and it’s me.)

I was assigning the hotkey to the wrong keyboard. Well, sort of.

There was an old Ancient Hebrew (hbo-Hebr-IL) keyboard, which I had removed, still listed in the Configuration > Hotkeys dialog. That is, I had removed that keyboard, but its listing stayed there in the Hotkeys dialog. And, when that dialog opens, it expands just far enough for me to see the old listing. (First screenshot, attached.)

I thought the old listing was the entry for the new, current, installation of the keyboard. I didn’t know the new installation of Ancient Hebrew (hbo-Hebr-IL) was listed further down. So, I was assigning the hotkey to the old listing.

When I expand the dialog screen, (second screenshot),

and assign a hotkey to the actual current installation of the keyboard, the hotkey works. (Third screenshot.)

So, my bad, and I apologize for taking your time.

By-the-way, I have uninstalled the desktop and all keyboards, and reinstalled them, and that old listing is still there. Any way to remove it?


#8

Thanks for the follow-up. That old keyboard is a Windows system keyboard; you should be able to remove it from Windows “Language preferences”.


#9

Thanks for the pointer. I went into Word > File tab > Options > Language, and it was there under Choose Editing Languages. I selected it and clicked Remove. So, Office doesn’t show it anymore.

However, Keyman Desktop 10.0.1108.0 still does. It doesn’t show in Keyman when I first install the Desktop and before I install any languages,

But, after I install sil-hebrew.kmp 1.7, it shows up along with the real SIL Hebrew keyboard,

I can live with this, now that I know to watch to which entry I assign my hotkey. But, it would be nice to have the false entry out of there.


#10

You removed the language from Word, but not from Windows. To remove the language from Windows, go to Windows Search and type “keyboard options”, select “Language and Keyboard Options” from the list that appears, and you should be able to remove the additional keyboard from there.


#11

@Marc_Keyman, I removed the Ancient Hebrew (hbo-Hebr-IL) entry from Windows’ “Region & language”. That took it out of the Keyman Desktop > Configuration > Hotkeys screen.

But, after I rebooted, the Hotkeys screen showed a “Unknown Local (qaa-Latn-001) - SIL Hebrew” keyboard. (So did Windows’ Region & language.)

After the next reboot, the Keyman Desktop initial screen also showed “Unknown Locale (qaa-Latn-001) - SIL Hebrew”.

To get rid of that "Unknown Locale … " business, I deleted the SIL Hebrew keyboard from Keyman Desktop > Configuration > Keyboard Layouts, and cold booted. That removed the Hebrew keyboard from Keyman, but “Private use (qaa-Latn)” then showed in Windows’ “Region & language” > “Preferred languages”. I "Remove"d that, and cold booted again.

Both SIL Hebrew and Private use (qaa-Latn) were gone from everywhere; so, I reinstalled SIL Hebrew 1.7. Now,

  • Keyman Desktop initial screen shows
    “Ancient Hebrew (hbo-Hebr-IL) - SIL Hebrew”
  • Keyman Desktop > Configuration > Keyboard Layouts shows
    “SIL Hebrew”
  • But, Keyman Desktop > Configuration > Hotkeys shows both
    “Ancient Hebrew (hbo-Hebr-IL) - SIL Hebrew” and
    “Ancient Hebrew (hbo-Hebr-IL) - US”

The Windows Taskbar language selector shows “Ancient Hebrew (hbo-Hebr-IL) SIL Hebrew”, and Windows Region & language shows “Ancient Hebrew (hbo-Hebr-IL)”.

If I’ve made a mistake, and you see what it was, I want to fix it. But, if this is a bug, I’m okay with leaving it this way, in hopes that someday you’ll see something that will trigger your recognition of what the problem is, and be able to fix it. I know how to assign a hotkey to the real Hebrew keyboard now; and I value your time.


#12

By-the-way, the SIL Hebrew keyboard is listed differently than the SIL IPA keyboard in Keyman’s initial screen. Does that indicate anything pertinent here?

Keyman%20Initial%20Screen%202018%2006%2021


#13

This is because the SIL Hebrew keyboard is set to the Ancient Hebrew language (hbo) but the SIL IPA keyboard is set to the English language. Since IPA symbols are phonetic symbols not necessarily connected to a given language orthography, I suspect it does not much matter which language the keyboard is associated with. But you can change what language a keyboard is associated with in the Keyman configuration dialog.


#14

Thanks, Steve, for the explanation. So, the Hebrew keyboard - language association doesn’t have anything to do with this problem.