Heidelberg input solution uses qwerty (american) keyboard layout instead of qwertz (german) layout

Hello,

I am using the heidelberg input solution for writing Sanskrit in Devanagari and transliteration. The problem is, that it is using the qwerty Us keyboard Layout. So when I am typing z I get a y and also other symbols are mixed up. I saw that someone had a similar problem in this thread, but there is no solution in the thread:

All my keyboard settings are set to german both in my windows settings and in my keyman settings. It’s still not using the german layout.

It would be very nice if someone could help out.

Could you give an example of the issue in question? Please provide both current and expected (or correct) output together with their respective keystrokes. These would help me to understand the issue better.

Also, please let me know specifically which keyboard that you have this issue with. There are 6 keyboards in this package.
image

AFAIK, the keyboards in the package work per their help documentation.

Thanks!

Yes I checked the help documentation and it is not working as it should. I have the problem with the "Devanagari Unicode [De] and the Transliteration [DE] keyboard: for example with the Devanagari Unicode [De]:

It outputs … when inputing the following:
y > ज़्
z > य्

Transliteration [DE]:
y > z
z > y

The main problem here is that as with the Devanagari Unicode [DE] Keyboard, the special charactors to modify the letters are in a different place:

for example input with the Heidelberg input solution on the left in the following list and the output as it should be on the right

  •  ß
    

= ´
´ +
^ #
/ -

etc.

So it seems to me that it it is using the qwerty keyboard as input instead of the german qwertz keyboard:

These ar emy settings:

On the options tab of Keyman configuration, what is set for the base keyboard? Can you select German there if it is not selected?
(in your German screenshot it looks like “Options” is Enshellugen, but I can’t see the print clearly. But it is the second choice in the left column). Base keyboard is the last orange button in the lower right of the white area.

Thanks!

The base keyboard is also set to german like my windows keyboard. Everything is set to german.

I believe I know what the issue is, I’ve investigated further and it seems as though selecting a base keyboard in Keyman configuration only affects mnemonic keyboard layouts, and it looks like the Heidelberg keyboards are all fixed position layouts. But I don’t know how to fix it except perhaps modifying the keyboards. There were links to send email to the keyboard developers in the keyboard description page:

https://keyman.com/keyboards/heidelberginputsolution

Or else you can try other Sanskrit keyboards to see if they work better.

Thanks a lot! Yes I will send an E-Mail to the developers and I will post the solution if there is any and if I get a response.