Google Play's target API level requirement


#1

Hello, Google is writing me in the console/developers news this:

Google Play will require that new apps target at least Android 8.0 (API level 26) from August 1, 2018, and that app updates target Android 8.0 from November 1, 2018.

So then we started looking, what our present App Builders (RAB, SAB, DAB) are producing. And we could not find this information. We looked inside the RAB and found an option to set the minimum-target, but not an option to set (or see) the maximum-target.

Also on the release notes page for RAB we could not find which version of RAB is producing apps with with maximum target:
https://software.sil.org/readingappbuilder/release-notes/

Please let us know, where we can look up what our present RAB installations are producing.

Each update is like surgery here, due to several people and several computers involved. And always slow internet. Still, since I am one of those shouting-for-more-features-guys, I am not against updates. Just this week needing to know whether “we are good with Google” for the rest of this year with our output.

Thank you.


#2

The target Android version is the version of the Android platform libraries that you are using to compile the app. Since Reading App Builder version 4.1 (December 2017), we have been using Android 8.0 Oreo (API 26) - so your apps built this year already fulfill Google’s requirements. See Tools > Settings > Android SDK.

When we release RAB 5.0 (in the next month or two), we will be upgrading the target Android version to use Android 9.0 (Pie) platform libraries.


#3

This is the information I was looking for. Very helpful and precise. Thank you very much.

You can consider this question “solved”, user is happy. Yet another reason to make the effort to keep up to date with our RAB versions.