Failed to prepare audio file

This is great! I was finally able to get books and audio onto the RAB and it actually made an App. All of the texts work great.
But I have the audio files on Internet Archive, and it won’t bring them into the app. The message I get after a brief effort at downloading is - “Failed to prepare audio file” Our internet is terrible here, so is it likely that is the problem, or am I doing something else that is keeping audio from downloading? I have assigned a separate source for each book, but maybe I have made some kind of mistake with that?
Any help I can get on this will be much appreciated.
Grace and peace,
Gene M.

I hope you have already solved this.

Others who have used have misunderstood what was the true URL of the audio file. To find the true URL of the file. Right click on one of the files and click on Copy link address (or similar).
That gives you something like this
And you need the part:
Note for the site it must have the word download/ in the path.
Some have mistakenly used this form: thinking that was the correct URL since you can listen to the files from there.

I just tried using Internet Archive to do some troubleshooting. I don’t know if they’ve changed their URLs, but I found that
wasn’t working for me. Nor did this URL load the song in my browser:

When I right-clicked on the “VBR MP3” option, I copied the link URL and got, for example,ämi.mp3

Aside from possibly not liking the ä character, it appears that it’s saving each file in its own subfolder.

I write this for the benefit of possible future Internet Archive users who are troubleshooting. I have gotten my app to download audio using another website.

Thanks for that, we live in a world that changes often.