Error installing v10.0.934 on Win 7


#1

When I tried to install Keyman 10.0.934 alpha I received an error message:
No argument for format ‘System Error. %d.%s%s’
I was installing over Keyman 9.0.528. Win 7 x64 sp1.


#2

Hi, I tried to reproduce the issue here on a Windows 7 test computer. However, I was not able to reproduce the problem. Could you use tsysinfo to send us a diagnostic report please?


#3

I just sent the diagnostic report. The same error message occurred with v10.0.947. The installation completed itself, and Keyman runs correctly.


#4

I’ve reviewed the diagnostic report but there was nothing obviously untoward in it. The error message itself was not present in any of the diagnostic logs; I am wondering if it may have been presented by a different process rather than the Keyman process itself? It’s hard to say for sure because while the message itself is not one that is present in Keyman, it could be present in the Windows Installer.

From here, it’s hard to know what to investigate further; if the issue is reproducible we could shadow you with TeamViewer and capture further diagnostics when the error arises. Up to you!


#5

Thank you, Marc. I won’t go any further with this. It appears to be a unique problem, and not an issue for me. I was just reporting it for the possible benefit of the community.