English letters are typed in special windows

Hi Keyman Devs,

I have installed Russian - Mnemonic Basic from Keyman Configuration on Windows 10. I have rebooted the OS and switched to Russian - Mnemonic Basic.

Screenshot 2022-07-05 180711

When I type in a file explorer, the Russian letters are typed. But in the browser or in the Windows’ search field English letters are typed, except for AltGr+8 which inputs Russian ruble ₽.

My Keyman Configuration is as follows.

By the way, the Keyman icon on the Desktop has the following image.

Screenshot 2022-07-05 175931

Has anyone faced similar issues?

I assume that you are referring to this keyboard:

I’m using the keyboard to type in Microsoft Edge’s address bar and else where, but the keyboard works as expected.

Could you give me more info that may help to reproduce this behavior?

I have set hotkeys to change input source.

I change the input language to Russian - Mnemonic Basic by Alt+Shift+R. I tried also to change by Win+Space or left Alt+Shift, but the issue still exists.
What is the proper way to change the input source to not interfere with Windows’ input languages?
Should the Windows language bar appear on the taskbar beside the Keyman icon?

My language bar options are as follows.

Also the Keyman version is 15.0.265.

Keyman’s hotkey setting and Windows’ language bar option do not have anything to do with how characters are output when using the keyboard.

Can you try and send a diagnostic report to us following the instructions here? I don’t have high hope though that this issue can be fixed as it cannot be reproduced on my side.

This may be related to certificates. Can you check the certificate status for C:\Program Files (x86)\Common Files\Keyman\Keyman Engine\keyman.exe:

  1. Open C:\Program Files (x86)\Common Files\Keyman\Keyman Engine in Explorer.
  2. Look for keyman.exe (it might just be shown as an Application called ‘keyman’).
  3. Right-click on it and select Properties.
  4. In the Digital Signatures tab you should see something like this:
  5. Click Details.
  6. The dialog that appears shows whether or not the digital signature is “OK”:
    image
  7. If the digital signature is not OK, can you click View Certificate, select Certification Path and check the status of each signature in the path?

Another possibility is the following article: [Windows] Keyman does not work with Skype, Windows Search or other Windows Store apps · Issue #1680 · keymanapp/keyman · GitHub

I have checked the certificate status for C:\Program Files (x86)\Common Files\Keyman\Keyman Engine\keyman.exe, it is OK.

Also, the Keyman and its subpackages have READ access for all applications as shown below.

I have run Keyman in debug mode as described in the article HOWTO: Run Debugging in Keyman Desktop.

I couldn’t send a diagnostic report as described in HOWTO: Send a diagnostic report to Keyman Support, because of the following issue.

Screenshot 2022-07-07 152820

But I can share the log files from %localappdata%\keyman\diag.

During the debugging, I closed all applications, started the Keyman, changed the input language to Russian - Mnemonic Basic by clicking on the Keyman icon and selecting it then opened the Chrome browser and typed in the address bar. The letters were English instead of Russian, but the symbols accessed by AltGr were as expected (e.g. AltGr + 8).

Okay, I’ve looked at the log. Keyman is working and there’s no issue with certificates or anything like that. The log reflects the symptoms you describe – I can see the translation of AltGr+8 but unmodified keystrokes are not being sent by Windows through Keyman, but direct to the app.

Can you check your keyboard settings in Windows? Do you have any of these options on?

image

My keyboard settings are as follows.

Can you try turning those two text suggestion options off? (You may need to restart Windows, not sure.)

Ref https://github.com/keymanapp/keyman/issues/4457

I have turned off text suggestions options and restarted the OS. All Keyman keyboards started to work as expected.

The issue is solved and can be closed.

Glad this fixed the problem for you! This is something we may try and see if we or Microsoft can resolve – text predictions should not be interfering with Keyman in this way :slight_smile: But it may take some time…

Issue recorded: https://github.com/keymanapp/keyman/issues/6933

I’ve reported this to Microsoft at Windows Insider. Please also report the issue via Feedback Hub and/or vote on my report!

Ok. I have voted for the issue in Feedback Hub.

1 Like